Permission Level VS Role

Describe the problem you would like to solve
In the UI, Role means UserGroup in the source code, and Permission Level means ROLE(_ID).
Maybe, rename Role::ROLE_ID… to something like Permission::PERMISSION_LEVEL_ID in source code could be great

Who is asking for this feature?
Technical Support who discuss with all users, and sometimes there are misunderstandings about these terms

Additional information
Just a suggestion :slight_smile:

Hi @kara28,

I hear you on this – we have many cases where the wording in the code has evolved differently than the wording in the UI! (Another example: Discussions in the UI are Queries in the code.) However, it can be very painful to change these – imposing a bulk search-and-replace on all plugin authors who refer to role IDs, for example – so we try to look for situations where a change becomes necessary and hit two birds with one stone.

At the moment we’re gradually adopting more Laravel tools, and are considering some role/group management tools; if their adoption looks like a positive move, we’ll standardize terminology along those lines.

Alec Smecher
Public Knowledge Project Team

1 Like