[OMP] Duplicate set / repository submission issue

,

When I try to add an OMP repository to WorldCat Digital Collection Gateway, the following error returns:

FAILED: Testing Set Uniqueness

According to the troubleshooting guide:

Testing Set Uniqueness
• If this test fails, it means that the repository returned a proper OAI ListSets response containing set information, but one or more of the setSpec identifiers are duplicated. The Gateway cannot work properly with duplicate setSpec identifiers because those are used to differentiate the collections in the repository. The user will not be allowed to add the repository with duplicate setSpec identifiers.

When I access the OAI interface of my press and list sets, there are two repeated occurences of setSpec, indeed. I have only one press installed. Oddly, another setSpec identifier has an old path used for this press.

I was eventually able to add the repository, but I’m unable to reach my books collection because of this error.

Could you guys help me to fix this issue? Clearing data and template caches didn’t work. I’m using OMP 3.1.1.4.

Thank you in advance.

I ended up to solve this by deleting content of tombstones tables straight in SQL, as pointed in this thread. But I wish there were a way to do that without putting hands on database.

EDIT: problem is still unsolved… I had to revert steps above because, without tombstones data, I cannot delete records from WorldCat. But then setSpec identifiers are duplicated again… Is this a bug in OMP? Any ideas to fix this?

Hi @fsaldanha,

Are you sure the duplication is related to tombstones? Is it possible that you have e.g. two series with near-identical information?

Thanks,
Alec Smecher
Public Knowledge Project Team

@asmecher Yes, I’m sure it’s somehow related to tombstones, or at least they are messing with the result.

I made a backup of my SQL, deleted all tombstones data and the duplicated set was gone. Once I reverted the deletion, the error returned. In fact, I even tried editing OAIDAO.inc.php and commented the portion related to tombstones (lines 101-113): this also temporarily solved the issue.

Check it out below: (I already reverted changes to core code)

BEFORE: WITH TOMBSTONES

1_sets

1_tombstones_oai

AFTER: DELETED TOMBSTONES

2_sets 2_tombstones 2_tombstones_oai

Hi @fsaldanha,
I have a duplicate set as well. You write it is temporarily solved by deleting tombstones. Did you happen to find a definitive solution?

Hello @tabber,
Unfortunately, the only way I found (sort of) to workaround this was editing OAIDAO.inc.php, as I mentioned above. I’m still expecting PKP staff could help me with a more definitive fix.

Hi all,

I’ve added a pull request here that should resolve it:

Please report back whether it resolves the issue, and I’ll make sure it gets added to the next release.

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher Great! Now it worked like a charm. Thank you for the attention and support.

HI @fsaldanha,

Thanks for confirming! I’ve committed this for release in OMP 3.1.2-1 (due out next week).

Regards,
Alec Smecher
Public Knowledge Project Team