OMP and list of the list of contributors

Hello all,

I am using OMP 3.1.0 and have some issues with the visibility of the list of contributors.

I would like to have listed only volume editors but not authors. I believe I have done everything properly but all the time the authors and the volume editors are listed. Here is how it looks like:

I have not check the authors to be listed in the list of contributors:

Further on I have excluded the author role to be listed in the list of contributors, but doesn’t help:

Any idea what is wrong?

Regards, Primož

Hi @primozs,

When you check off whether to include the contributor in browse lists, it actually doesn’t affect whether their name appears at top of the monograph page. “Browse list” refers to the monograph metadata that will appear in a search result or a featured page.

Where you unchecked “Show role title in contributor list,” I think this just refers to showing the role title (author, editor, etc.), not the name of the contributor.

There is currently no way to remove the author listing from the top of the monograph page, but an issue has been filed for this feature on github: Limit display of names to editors in edited volumes · Issue #2426 · pkp/pkp-lib · GitHub

Amanda Stevens
Public Knowledge Project Team

1 Like

Hii everyone

I´m present the seme problem, any solution for this issue??

How can diference the editor of the volumen for the authors list in the presentation page.


Im waiting for any answer!

Many thanks,