[OMP] Custom Locale Plugin does not show empty strings

We’ve just updated from OMP to OMP

In the process, we lost all custom translations for our German locale (which we expected, since the Translate Plugin is now obsolete), but now it looks like we can’t put them back in using the new Custom Locale Plugin (which we didn’t expect).

The problem is that we know which strings we need to translate (for example, ##submission.editorName##, which currently only shows up as the base string in the frontend) and we know which locale files they’re supposed to be in (locale/de_DE/submission.po), but the locale files refuse to show empty strings to be filled.

If I check on any de_DE locale file in the backend (using the CL plugin), it ONLY shows strings that have a value - which I can then edit, but it doesn’t show me ANY of the strings that are completely empty. If I switch to looking at the English locale files, I can see that the strings are clearly there. The file “plugins/themes/default/locale/en_US/locale.po” for example includes 16 strings, the equivalent German file only has 2 - I cannot see, much less edit the 14 empty strings.

We have presses that have German as the primary locale and presses that use English as the primary - doesn’t seem to make a difference.

What can we do?

I had the same problem.

if you are comfortable with linux shell:
a) go to the main OMP installation (e.g. /var/www/omp)
b) write this command
grep -rnw . -e 'string'
(substitute string with the phrase are you loocking for)
c) open the file reported in the output (please not consider files in cache folder) with vim or your preferred text editor and change the translation.

Why don’t you download and use the language file from here https://translate.pkp.sfu.ca/projects/omp/#languages?
Could there be a reason I don’t know?

For Turkish, I am using the language file here.

HI @piapio

I believe the same issue but on the OJS: OJS Custom Locale Plugin: language cannot be changed - #3 by felixhelix

Regards, Primož

Sorry, not the same issue. The search bar at the top of the custom locale plugin lets me search (in all activated locales) the various locale file names, not the keys/strings within the locale files. Again, I CAN look at the German locales files, just the keys I need to fill in aren’t visible for me to edit.

Hi @kerimsarigul

I think I’m going to have to fix the issue the way you suggested, by editing the locale files manually and handing them off to our IT to put them on the server. The point of this post was more to see if there is any way I can do it with just the Custom Locale Plugin, as I believe that I should be able/allowed to customize empty keys with the plugin. When using the Translator Plugin on older OMP installations, you could fill empty keys and it feels like an odd choice to deliberately remove that option and only allow users of the plugin to edit existing key values.

Thanks for the reply though :wink:

1 Like