[OJS] Blank, white page ("Search" function)

But for these tests I changed only the OJS installations. I used the old DB for both. And it worked only in the new installation.

Hi @riquemg,

Do I understand correctly that you have one database server, and two web servers (each with their own OJS installation), and trying to connect to the same database on the same database server from the two different web servers has different results?

Alec Smecher
Public Knowledge Project Team

@asmecher sorry, my fault.

It works only when I use a clear OJS database and populate it with my old datas.

I will make more tests and return for a feedback.

1 Like

Hi @asmecher,

I’m feeling so dumb, lol.

I changed, this: connection_charset = off
For this connection_charset = utf8

This line is new?

Sorry for that…

1 Like

Hi @riquemg,

That line isn’t new; maybe you missed it while migrating your settings in config.inc.php during the upgrade.

Glad it’s solved, and thanks for following up – it might save someone else the same trouble!

Alec Smecher
Public Knowledge Project Team

1 Like

Hi, i had the same problem and recently solved this

i tried the same as @bricas but doesn’t work for me, so i do a php script for alter all tables, maybe can help somebody

// your connection
$dbHandler = new PDO('mysql:host=localhost;'.'dbname=ojs_test;charset=utf8', 'user', 'password');

// convert code
$sqlQuery = "SHOW TABLES;";
$query = $dbHandler->prepare($sqlQuery);
while ($row = $query->fetch(PDO::FETCH_OBJ)){
    foreach ($row as $key => $table){
        $convert = "ALTER TABLE " . $table . " CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci";
        $queryTable = $dbHandler->prepare($convert);
        echo $key . " =&gt; " . $table . " CONVERTED \n";

Helpme, donde puedo pegar ese codigo?

ayudame a hacerlo, tengo el mismo problema, por favor

Hello @Efren_Lobo,

This is an older post and may not be actively monitored - you may wish to create a new post and describe your issue there.

PKP Team