[OJS 3.1.2.4] Strange behavior when assigning participants

Hello all, @asmecher, @ctgraham,

OJS 3.1.2.4 is behaving strangely when starting to process a submission.
After submission is completed by author, we must assign participants.
However, there are times when OJS lists Production Designer, sometimes it lists Editors.
Although OJS has an update, which seems to have improved several aspects of OJS 3, we hope that this erratic behavior is not present in the current verions.

Hi @ramon,

Thanks for your question. Kindly see this related forum post - [OJS 3.1.2.4] Automatically assigning a user with assistant permission to new submissions - #5 by pmangahis for the rationale on this.

If you do have multiple Editors enrolled in your journal, it would be helpful to check whether you have set up your Sections to automatically assign submissions to Editors.

Kind Regards,
Patricia

Hello @pmangahis ,

I’m aware of the automatic assignment of users to sections. This has been an OJS standard since 2.x, if memory serves (if not by 1.7!!). That’s not the strange behavior I’m referring to.

We have no users assigned to sections (although we also have a few users assigned the section editor role), so the automatic assignment does not happen in our journal. We plan on using this feature when dealing with Thematic Issues.

What I’m dealing with, and it’s annoying as it is strange, is that SOMETIMES, not always, when opening the modal window to assign an editor, instead of viewing the list of Editors, I see the list of participants filtered by Production Designer role already.

I have to select Editors from the pulldown menu and then hit search to view the Editors, which are the 3 ones that are responsible for seeing the submission through the editorial process.

This behavior also happens, again SOMETIMES (and I haven’t found a common denominator as to why this happens!) when I open the modal window again, once I have already assigned one of the editors without the role of Production Designer. The list is filtered by Production Designer again, despite selecting Editors previously. This was worse when there were 2 users with the Production Role assigned.

Now, since there’s only one, I assign that Editor first. Then, there’s no Production Designer left, so Editors are the first listed. However, from time to time, I still need to change the role filter when assigning the first editor to the submission, if the Production Designer is the one presented.

Our editorial team is composed of 3 journal editors and currently, only one has the Production Designer role assigned to him. We had to assign this role to 2 editors for testing purposes, because there were submissions not even Editors had access to at later stages of the editorial process (file download was unavailable, or editing or production stages were blocked, or assigning submission to an issue for publishing, or the publishing button was unavailable!).

I could assign the 3 editors to our main sections, but that would send the submission automatically to review, and there’s a pre-review stage we go through and we don’t want authors to be led to believe the submission is in review, when in fact it isn’t.

Hi @ramon,

Thanks for providing some additional information regarding this issue. Unfortunately, I am unable to replicate the issue you’re having and don’t see any related issues for this report.

As the version of OJS that you’re using is now quite old. I recommend that you upgrade to the newest version of OJS, as it is possible that your issue will be resolved by upgrading. However, other community members may wish to offer assistance.

Upgrading instructions are available in the PKP Administrator’s Guide.

Information about the latest version of OJS can be found on the PKP Website

Kind Regards,
Patricia
Public Knowledge Project Team

Hi @ramon

I fall today with same stone. Did you manage to fix the issue?

Cheers,
m.

Hello @marc ,

I’m not sure if it’s related, but applying the patch to the user search fixed most of our current problems.

Since I have multiple roles, we use multiple languages, have multiple journals sharing registered reviewers (the researchers, not necessarily the registered user), that may have something to do with what we see when assigning reviewers;

I haven’t noticed this behavior anymore lately.

We are currently on OJS 3.3.0.8 with the patch applied to user search, available here:

I read your post twice and is not our case.
Our is related with this new feature in OJS3:

Sorry for the annoyance Ramón.
Happy you finally made it work.

Cheers,
m.

Hello @marc ,

Yes, indeed.
Our strange behavior is not related to automatically assigning anyone, as this doesn’t happen in our journal.
What happens is that the modal window that appears when assigning participants shows different roles every time. Sometimes, the Production Manager list, sometimes editors, journal managers, there is no default or pattern.

We haven’t run into this again as our submissions are temporarily closed and we’re dealing with the submissions in review that are late.

1 Like