Ojs wont install

I’ve uploaded the files and every time I run the install it just refreshes the page. http://jaawge.com/error_log.txt

Its on a shared hosting Linux hosting with cPanel on godaddy, php version 7.2 , libmysql - 5.1.73

This could happen if the web server was not able to write the configuration to config.inc.php.

Permissions for all of those folders and file are 0755

Note that permissions cannot be expressed by simply the numeric value. This is interrelated with the user and group ownership and the user under which the webserver runs.

That said, if you are confident that the permissions are set correctly, try looking in your PHP error log for lines with “Error” or “Fatal” in them. The “Warning” and “Deprecated” messages are less helpful in identifying the issue.

In my original post I linked my error_log and described by hosting environment. The file permissions are set by a numerical value for folders and files on the hosting account.

The only other result I can get is a HTTP ERROR 500 that gives me the url /index.php/index/install/install

I’ve installed OJS twice before and haven’t run into this issue.

Hi @Pippin,

I faced exactly the same problem, but could finally install the software using the terminal of my local Linux installation.
You can find full instructions on the same page.
Nevertheless, I could’t figure out the reason for this issue, but it seems that the database is not accessible by PHP script.
I posted about this issue here. Others are having the same problem too.

Good luck installing,

Thank you, is there any information on installing OJS using the terminal for Linux?

After doing some reading and retrying the install on another hosting account, I found manually updating the config.inc.php with the already created mysql database information and changing the mysql to mysqli seemed to work.

Hi @Pippin,


didn’t work with me.

Glad to know you found a way out.

I haven’t personally been able to reproduce this problem. I just tried a fresh install of OJS 3.1.1-4 on a RHEL7 variant with PHP7.

Both the linked posting and this posting end the error log with a message like:

PHP Warning: count(): Parameter must be an array or an object that implements Countable in /home/iesap/public_html/revista/cache/t_compile/e8ea13aa559bf8604ca823015b397a28d8666486^%%8B^8BC^8BC56207%%usernav.tpl.php on line 100

This line counts supported locales.

What locale(s) are you selecting for the Primary and Additional locales at installation?