My publication’s articles are not appearing in my PKP Index record

Application Version: OJS 3.2.1.1

PKP Index Record: https://index.pkp.sfu.ca/index.php/browse/index/7909

Description of issue: My publication’s articles are not appearing in my PKP Index record.

Steps you took leading up to the issue: I registered at PKP Index and the status is: Approved. There are no errors with OAI, according to the publication’s settings page (https://revistaideas.ufrrj.br/ojs/index.php/ideas/oai). I read the FAQ page of the PKP Index. All the individual articles are added to the issue’s Table of Contents. The FAQ page indicates this forum post, but it is unavailable.

How can I solve this problem?

Hi @Francis_Z,

The link you posted is to this post – it looks like a period (.) got attached to the end of the link.

The problem appears to be that your OAI repository_id is not unique. I’d recommend setting the repository_id to something more personalized in your OJS config.inc.php configuration file. It should be whatever you like, but should not be something that another journal might use.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher!
Thank you for your help. Our repositoy_id was changed to something unique ojs.revistaideas.ufrrj.br in the file config.inc.php
However, the problem remains, because the articles that appear in “browse” are not from my journal.
I have already repeated step 1 “fetch information” on the “edit publication” page.

Hi @Francis_Z,

I’ve flushed and re-harvested your journal’s list in the PKP Index and you should see the entries beginning to work again.

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like