Metadata error: Please enter the title of your article. (English)

Hy,

my Client has report following erroer in their ojs 2.4.8.1:

when they try to edit metadata of article in editing they always get this error: Please enter the title of your article. (English). They say they have try to fill out title in every language, but in every language it is a same thing: They enter the title of article, click on save and it shows this error with blank field of title.

I would like to know where is the code for this form? This is the Form which is visible when you click on Edit Metadata inside single Article.

Update:
I have found template and there it says: {if count($formLocales) > 1} then shows div with id locales and everything in it. Journal has 2 languages but on form page there is no div with id locales. Like it doesn`t recognize variable $formLocales. I see this variable is used also for title and abstract of article. It seems there is the problem with this variable or some setting. Where is defined this variable?

Hi @suzy,

As Journal Manager, check the Languages settings page to ensure that valid options are specified for both Forms and Submissions.

On the first step of submission, the author will be required to choose a Submission language (if multiple options are available). Thereafter, they’ll be forced to enter certain required fields (e.g. titles) in at least that one language.

Regards,
Alec Smecher
Public Knowledge Project Team

Hy @asmecher,

thank you very much! This was the right solution for this case :slight_smile:

1 Like

I just wanted to confirm there’s no way to leave the title empty for the primary language, when the title is not empty in another language.

Our journal is primarily in Portuguese, but a few articles are in English only.

It’s OJS version 2 (2.4.8.0).

Thanks,
-Felipe.

Hi @fgnievinski,

If you’ve enabled several submission locales, then step 1 of the submission process should include a drop-down where you can choose the submission’s locale. For English-only articles, the author should choose English; if that’s done, then the required fields (e.g. titles) will only be required in English.

Regards,
Alec Smecher
Public Knowledge Project Team

Dear Alec,

I can confirm that under Journal Management > Languages, we’ve checked “Submissions” for more than one “Supported locales”. I also note that the “Primary locale” field allows a single unique selection.

The problem arises when we try to edit the article metadata, it says:

Errors occurred processing this form:
Please enter the title of your article. (Português (Brasil))

But there is already a title and abstract in the English version of the metadata form, hence our surprise.

The title and abstract fields have a footnote: “* Denotes required field”.

Regards,
FGN

I also tried changing the Language field in the Indexing section of the Edit Metadata form, from pt to en, to no avail.
FGN

Furthermore, I tried changing the Language field in the Edit a Layout Galley form, to no avail.
FGN

Dear @asmecher, just wondering if you’d have any other suggestions, in addition to our attempts above, please.
Thanks,
-FGN.

Hi @fgnievinski,

I’ll try to duplicate this behavior locally. Can you provide me with…

  • A screenshot of the “Languages” setting form in journal setup, and
  • The value of the locale column in the submissions database table for the submission you’re having trouble with?

Thanks,
Alec Smecher
Public Knowledge Project Team

Dear @asmecher:

here’s the screenshot requested:

image

I’ve asked our IT support for the database information.

Thanks for your assistance.

Best,
-FGN.

I’ve also tried creating a new submission (using the QuickSubmit plugin) and I’ve found something interesting.

First note there are several Language fields:

  1. OJS’ general “Select Language” on the right-hand side;

  2. QuickSubmit’s “Form Language” at the top of the form, which says:
    “To enter the information below in additional languages, first select the language.”

  3. QuickSubmit’s “Submission Language” in the middle of the form, which says:
    “This journal accepts submissions in several languages. Choose the primary language of the submission from the pulldown below.”

image

Ignoring field 0, I tried the following combinations:

a) both 1 and 2 in English: submission accepted

b) both 1 and 2 in Portuguese: submission accepted

c) 1 in English and 2 in Portuguese: submission rejected:
Errors occurred processing this form:
Please enter the abstract of your article. (Português (Brasil))
Please enter the title of your article. (Português (Brasil))

d) 1 in Portuguese and 2 in English: submission rejected:
Errors occurred processing this form:
Please enter the abstract of your article. (English)
Please enter the title of your article. (English)

So it seems there’s a bug in the QuickSubmit plugin?

Thanks,
-FGN.

Now trying to rectify the submissions already made using the QuickSubmit plugin, I note in the database scheme that the “submissions” table has two related columns: “locale” and “language” – would it suffice to set both to English?

<!--
  *
  * TABLE submissions
  *
  -->
<table name="submissions">
	<field name="submission_id" type="I8">
		<KEY />
		<AUTOINCREMENT />
	</field>
	<field name="locale" type="C2" size="14" />
	<field name="context_id" type="I8">
		<NOTNULL />
	</field>
	<field name="section_id" type="I8" />
	<field name="language" type="C2" size="10">
		<DEFAULT VALUE="en"/>
	</field>
	<field name="citations" type="X"/>
	<field name="date_submitted" type="T"/>
	<field name="last_modified" type="T"/>
	<field name="date_status_modified" type="T"/>
	<field name="status" type="I1">
		<NOTNULL/>
		<DEFAULT VALUE="1"/>
	</field>
	<field name="submission_progress" type="I1">
		<NOTNULL/>
		<DEFAULT VALUE="1"/>
	</field>

	<field name="pages" type="C2" size="255"/>
	<field name="hide_author" type="I1">
		<NOTNULL/>
		<DEFAULT VALUE="0"/>
	</field>
	<field name="stage_id" type="I8">
		<NOTNULL/>
		<DEFAULT VALUE="1"/><!-- WORKFLOW_STAGE_ID_SUBMISSION -->
	</field>
	<descr>Submissions</descr>
	<index name="submissions_journal_id">
		<col>journal_id</col>
	</index>
	<index name="submissions_section_id">
		<col>section_id</col>
	</index>
</table>

Actually, in OJS 2 the equivalent to the “submissions” table in OJS 3 seems to be the “articles” table, which has both columns “locale” and “language”:

There’s also an “article_settings” table, which holds the metadata, and contains a “locale” column, too (but no “language” column).

So it seems there are several places where the language/locale can be recorded. I’m suspecting the QuickSubmit plugin failed to set one of these columns?

Thanks,
-FGN.

IT sent us the database snippets:

Screenshot_20180628_115158

and:

Screenshot_20180628_115833

@asmecher, please let us know if any further information is needed.

Thanks,
-FGN.

Dear @asmecher, sorry to bother, but did you manage to replicate the problem on your end?
Thanks,
-Felipe.

I’ve found an answer here:

It’s currently a feature request:

So it seems the only solution currently is to delete the mixed submission and then resubmit it, this time making sure that both QuickSubmit’s “Form Language” and “Submission Language” fields are set to English: