License disappears after upgrade to 3.2.1

  • Application Version
    OJS 3.2.1-1
    Theme: Default
  • Description of issue
    After upgrading, no license information appears on published submissions, even when an override is set.
  • Steps you took leading up to the issue
    Upgraded from 3.1.2
  • What you tried to resolve the issue
    Unpublishing and (re) publishing on the article or issue level makes the license appear for the relevant articles.
  • Screenshots

No license:
Screen Shot 2020-07-10 at 1.37.13 PM

But override set:
Screen Shot 2020-07-10 at 1.40.43 PM

After unpublished/(re)published
Screen Shot 2020-07-10 at 1.38.26 PM

I am encountering the same Issue (OJS 3.2.1-1; bilingual journal). According to the database, everythin seems to be in order:

select * from publication_settings where setting_name like "%lic%" limit 3;
| publication_id | locale | setting_name | setting_value                                 |
|              1 |        | licenseURL   | |
|              2 |        | licenseURL   | |
|              4 |        | licenseURL   | |

Is there any solution yet (that preferably does not involve changing the articles or their metadata)?

Thanks in advance!

As a follow up, it seems to me, as if the fieldname now is “licenseUrl” instead of “licenseURL”. Manually changing this in the Database brings the Information back in the article view. Maybe there is way to solve this, without modifying the database manually?


Hi @thf, thanks for this. Yeah that does seem to be the issue, although our db was also missing the license urls, so I had to also update that as well. To fix the setting name I just issued the command

UPDATE publication_settings SET setting_name = 'licenseUrl' WHERE setting_name = 'licenseURL';
#check to make sure everything looks right

I’d test it out on a copy of the database or in a dev environment first. I’m not sure what the non-db version would look like but this was pretty painless.


Hi all,

It looks like the update to publication_settings was forgotten as part of Test licenseUrl context setting · Issue #5445 · pkp/pkp-lib · GitHub – I’ll add that to github for subsequent releases. I can confirm that the solution you found is good, @IOPNdev.

Alec Smecher
Public Knowledge Project Team

1 Like

We had that too in our 3.1.2-4 to 3.2.1-2 upgrade. Thanks for the pointer.

Kind regards,


We had the same problem, but when upgrading from OMP 3.1.2 to The licenseUrl/URL fix above solved it, but a bit unexpected that it happened again.

/Magnus A