Jounal not being created

Hi @Altaf_Bankotkar,

Look for something containing the word “Error”; that warning is harmless and shouldn’t cause problems.

Regards,
Alec Smecher
Public Knowledge Project Team

In today’s date, there are 9 other warnings showing the same thing. No error.

Hi @Altaf_Bankotkar,

Are you using rewriting rules, e.g. with Apache’s mod_rewrite, to alter the URLs to your installation? Check your browser’s developer toolset to see what URL the request is being sent to when you try to create the journal; for some reason, this URL is not being recognized by OJS when it tries to process the request.

Regards,
Alec Smecher
Public Knowledge Project Team

No, I’m not aware of rewriting rules. If you mean the settings in my config file, it looks like this:

; Use URL parameters instead of CGI PATH_INFO. This is useful for
; broken server setups that don’t support the PATH_INFO environment
; variable.
disable_path_info = On

; Use fopen(…) for URL-based reads. Modern versions of dspace
; will not accept requests using fopen, as it does not provide a
; User Agent, so this option is disabled by default. If this feature
; is disabled by PHP’s configuration, this setting will be ignored.
allow_url_fopen = Off

; Base URL override settings: Entries like the following examples can
; be used to override the base URLs used by OJS. If you want to use a
; proxy to rewrite URLs to OJS, configure your proxy’s URL here.
; Syntax: base_url[journal_path] = http://www.myUrl.com
; To override URLs that aren’t part of a particular journal, use a
; journal_path of “index”.
; Examples:
; base_url[index] = http://www.myUrl.com
; base_url[myJournal] = http://www.myUrl.com/myJournal
; base_url[myOtherJournal] = http://myOtherJournal.myUrl.com

Can you please help me with where exactly I have to look in developer tools?

Hi @Altaf_Bankotkar,

Ah, I see that you’re using disable_path_info. If it’s at all possible I would strongly recommend against using that option – in fact, we’re likely to remove it from future releases. It’s a work-around for “broken” web servers, and causes parts of the system, e.g. the OAI-PMH interface, to break their specifications.

Regards,
Alec Smecher
Public Knowledge Project Team

You mean I should turn > disable_path_info to off?

Hi @Altaf_Bankotkar,

Yes, set disable_path_info to Off.

Regards,
Alec Smecher
Public Knowledge Project Team

If I turn it off, The website does not work at all:

Hi @Altaf_Bankotkar,

That’s an issue with your web server configuration, rather than OJS; here’s a thread with some suggestions on how to set up your web server so that the PATH_INFO variable works as it should: About Restful Url with PHP CGI/FCGI

I’d suggest spending some time getting it working with a test script, then come back to OJS and see if that fixes things.

Regards,
Alec Smecher
Public Knowledge Project Team

I made the test.php file, shows the following on the browser:

And no matter what words I put in the path, the request header always shows the following:

Hi @Altaf_Bankotkar,

Your server isn’t delivering the PATH_INFO CGI variable correctly to the PHP environment – notice how it’s delivering it as ORIG_PATH_INFO instead. See [OJS3.0.2] Webserver delivers [ORIG_PATH_INFO] instead of [PATH_INFO] for some discussion of this and at least one suggested work-around.

Regards,
Alec Smecher
Public Knowledge Project Team

For anyone out there having the similar problem, my issue has been resolved by doing the following.
I Uploaded the php.ini file in my server. This file can be found on etc/php/7.2/apache2

Just copy this file and upload on your webserver

Hello Altaf, could you give more detail? I have the same troubles after upgrading OJS… Where exactly did you copy this file?
Thanks for your help!

in the root OJS installation file (where your config.php file is also located)

I didn’t find a file php.ini nor a etc/php/7.2/apache2 directory

give me your mail ID, i’ll send you the file. Just paste it in your root installation folder where config.php is located.

this is my mail:
pstgregoire@gmail.com

sent Peter… good luck

can you send me the file to me

nasserfuzt@gmail.com

please also send to my email deewahyu@gmail.com