Issue with supplementary files in upgrading from OJS 2.4.8-1 to OJS 3.2.1-1


When I upgrade from 2.4.8-1 to OJS 3.2.1-1, the supplementary files do not appear on the submissions.

However, if I upgrade from 2.4.8-1 to 3.1.2-4, the supplementary files are loaded correctly.

I have checked the databases, and after upgrading to, the supplementary file entries are created in the “submission_galleys” table. However, if I upgrade to 3.2.1-1, there are no supplementary file entries in the “publication_galleys” table.

No errors during the upgrade and in the php_log

Thank you very much.

1 Like

Hi @juanf.csic

When you say the supplementary files do not appear on the submissions do you mean they are not even in galleys?

We have previous posts where some users had to manage a few issues with supplementary files. Would you happen to have a look?

There is also a patch that prevents supp files from being migrated as galleys and migrates them as submission files. Please see it here: pkp/pkp-lib#3016 patch not to migrate supp files as galleys but as su… by bozana · Pull Request #2021 · pkp/ojs · GitHub

OTOH, if you want to keep supp files loaded in submissions you can make a two step upgrade:
from 2.4.8-1 => 3.1.2-4
from 3.1.2-4 => OJS 3.2.1-1

I hope it helps.


Hi Israel,

Thank you very much for your help.

In our journals (OJS 2.4.8-1), some articles have supplementary files that must be visible through the reading tools.

If I upgrade to OJS 3.1.2-4, those supplementary files become galleys as research materials. However if I upgrade to version 3.2.1-1 the supplementary files disappear.

A few days ago, I tried the two-step upgrade 2.4.8-1 => 3.1.2-4 and 3.1.2-4 => OJS 3.2.1-1 and it works. So it must be a issue in the direct upgrade 2.4.8-1 => OJS 3.2.1-1.

But I have to upgrade 37 journals with their own OJS installation, and this could be horrible (74 upgrades)

I have made a submission in OJS 3.2.1-1 with a galley as research materials, and I have published it. Then I have checked the entries in the database, and I have compared it with an upgraded journal 2.4.8-1 => OJS 3.2.1-1.

I have checked that in the upgrade 2.4.8-1 => OJS 3.2.1-1 are all the entries in the database except the entry to the table “publishing_galleys”

I solved it by adding the missing entry in the “publishing_galleys” table after upgrading 2.4.8-1 => OJS 3.2.1-1

Thank you very much.