Installation of OJS - PHP and MYSQL version

Hello everyone,

I read the OJS installation manual and I saw that the recommended server requirements were :

  • PHP >= 5.6
    • MySQL >= 4.1 or PostgreSQL >= 9.1.5
    • Apache >= 1.3.2x or >= 2.0.4x or Microsoft IIS 6
    • Operating system: Any OS that supports the above software, including
      Linux, BSD, Solaris, Mac OS X, Windows

My question is … Does OJS work with PHP 5.4 and MySQL 5.6?

Regards and thanks for your help!!!

OJS (stable) = Yes
OJS 3.1 = No

If you want to perform fresh installation please use OJS 3.1.0-1 with PHP 5.6. PHP 5.4 is not supported by PHP developers and it can have security holes.

Thanks, Diego!!!

And what about MySQL, Does OJS work with MySQL 5.6 without problems?

Thanks, Vedran!

I really appreciate your help.


Can OJS 3.1 work with PHP 5.5? Our university hosting uses only dedicated servers with PHP 5.5 only. Today I asked a question in our technical support and they told me that they have no plans to raise the version number of PHP. What can be the problem when using PHP 5.5?

There was somewhere the info at this forum that minimum PHP version number is 5.6 (But I don’t remember why). Maybe you will find this unswer from PKP team usefull: OJS 3.1: Why Exactly This Requires PHP 5.6? - #8 by asmecher
Interesting, and did you ask you technical support why they tend to use a quite outdated version of PHP? It was released 5 years ago and its support has ended in 2016.

Thanks @Vitaliy ! As I understood from this topic, the main reason for using PHP 5.6 is its potentially greater security compared to previous releases of PHP. In tech support I was not hear any reason to stay on an outdated version of PHP. In my opinion this is due to the unofficial “motto” of system administrators “It works? Don’t touch it!”.
Through MAMP I conducted an experiment on my test machine. In MAMP you can change PHP version for the test domain on the fly. And I installed OJS under PHP 5.6. After that in MAMP I changed PHP version to 5.5. Everything works (it seems). However, it is possible that some parts of OJS may not work correctly. And I’m worried about this.


The System Requirements are:

To run OJS 2.x, your web server will need:

PHP 4.2.x or later (including PHP 5.x) with MySQL or PostgreSQL support
A database server: MySQL 4.1 or later OR PostgreSQL 8.0 or later
UNIX-like OS recommended (such as Linux, FreeBSD, Solaris, Mac OS X, etc.). OJS 2.0.2 and above supports Windows servers (including IIS).

Yep, the best approach would be to try running and tracing occurring errors. And if you encounter one, try to solve it with stackoverflow.

Thanks, @Vitaliy. I’ll go “step on the mines” )))

Usually they maintain the version supported by the operating system vendor.

Ex: In ubuntu 14.04 LTS is version 5.5.9
In Ubuntu 16.04 LTS is version 7.0.4
The next LTS will be 7.2.x

It seems to me that the last centos / RHEL uses php 5.4.x

If it’s a large server full of things running, the OS version upgrade can be more complex.
But today we have virtual machine, docker etc. It is possible to have greater flexibility as the software versions, libraries, etc.

We who have hosted hundreds of magazines will use Ubuntu LTS 14.04 for OJS 2.4.x and we will adopt the 18.04 (next LTS) to be released next month for OJS 3.x. And we already use separate VPS for magazines that use OJS 3.

Besides the security issues, I think that the main reason for 5.6 requirement was the Slim framework that OJS started to use and that requires 5.6. At least for me with an older version of PHP for example the submission listings did not work in 3.1., but the old version I used was 5.4, so I do not have any experience with OJS/Slim and 5.5.

BTW… be carefull if you are too much “up to date”: PHP :: Bug #74461 :: mysqlnd error on utf8mb4 charset used by MySQL 8.0
It took me half day to find. :frowning: