How to make Google Scholar harvest the OMP metadata

Hi Alec
Has it been addressed in the OMP 1.2?
Niels Erik

Hi @nef,

Short answer yes. Long answer, I’m just finishing up a conversation with Google Scholar about officially turning on OMP support; when we wrap up the last few details I’ll post links to a few small patches that you’ll need to apply to OMP 1.2. You’ll probably also need to review your collection to ensure that a few requirements are met e.g. for publication dates. Stay tuned.

Alec Smecher
Public Knowledge Project Team

Great to hear that.

Any news concerning the Google Scholar support in OMP?

Hi @nweiher,

We haven’t been able to get confirmation from Google Scholar yet, I’m afraid.

Alec Smecher
Public Knowledge Project Team

Dear Alec good day,

Doy you have any up about this thread?


Cristhian Rey

Hi @Cristhian_Andres_Rey,

No, not yet.

Alec Smecher
Public Knowledge Project Team

Hi @asmecher,
Any news from Google Scholar on this feature?

Hi @Ikhwan_Arief,

I’m afraid not; I’d suggest contacting them directly to inquire.

Alec Smecher
Public Knowledge Project Team

Thank you. :slight_smile:


I have seen that a few years ago Google Scholar did not index OMP, currently it does? If I activate the plugin does it work?

Thank you.

Hi @InfoDocu,

OMP meets the needs of Google Scholar, so yes, as far as I’m aware. If you find that your content is not indexed in Google Scholar, and the OMP Google Scholar plugin is enabled, please follow up with Google Scholar.

Alec Smecher
Public Knowledge Project Team


Hi @asmecher, we have double checked with Google Sholar and currently OMP Google Scholar plugin is not working properly. There is an issue with citation_tags at the books’s landing page: OMP: Google Scholar tags only appear on PDF view page, not on landing page · Issue #5686 · pkp/pkp-lib · GitHub

Arley Soto

Hi @asmecher @asoto and I spoke this morning. They have enabled the “Google Scholar Indexing Plugin” for their OMP site, but this plugin is not creating citation_xx metatags for item-level landing pages.

Ex: view-source:

The are citation_xx metatags enabled for PDF wrappers, but view-pdf wrappers are not full-fledged article pages and are not indexed by Scholar as articles/books.

This appears to be a bug. Would it be possible to fix this so that the Google Scholar plugin adds citation_xx metatags to the HTML source for item-level landing pages?

Monica Westin, Google Scholar partnerships lead/ technical program manager

1 Like

I am trying to follow as we are new in thus field. We have the same problem with our OMP. The Google Scholar plugin is enabled from January 2020 but still no indexing. The site is E-izdanja. Can we please have some step by step guide to fix this? A rather simplified please, since we have only little technical support at our Faculty.
Many thanks from enthusiasts from University of Belgrade

asmecher, I think the issue is well described Monica Westin, Google Scholar partnerships lead/technical program manager.

Simply put: OMP adds the Dublin Core metadata to the “head” of the abstract page of a book, elements like:
link rel=“schema.DC” href=“
meta name=“DC.Creator.PersonalName” content=“Santiago del Hierro”
meta name=“DC.Date.created” scheme=“ISO8601” content=“2020-12-01”
meta name=“DC.Date.dateSubmitted” scheme=“ISO8601” content=“2020-12-01”

but the citation_xx metatags are added to the of the download page that has the PDF plugin.
Here you find elements like:
meta name=“citation_isbn” content=“9789463663427”
meta name=“citation_author” content=“Santiago del Hierro”
meta name=“citation_author_institution” content=“TU Delft, Architecture and the Built Environment”

Monica describes this as a bug.

I notice that OJS puts the Dublin Core and the citation_xx metatags BOTH in the “head” of the ABSTRACT page. I understand the comment by Monica that OMP needs a similar solution. The citation_xx metatags need to go to the of the abstract page like the Dublin Core metadata.

And yes, I would like to stress the importance of Google Scholar Indexing.

Hi all,

Also filed here: Google Scholar's indexing of OMP is still not working · Issue #6493 · pkp/pkp-lib · GitHub

I’ll ask someone to take a look shortly!

Alec Smecher
Public Knowledge Project Team

Hii @asmecher
Is there any solution to this problem? In my particular case I have the problem that my OMP does not harvest the metadata with Google Scholar as well @Marijana_Petrovic

What could be done about it?

I will be very grateful for any information!



Hi @Nikola,

The issue linked above should be resolved in OMP 3.3.0. If you’re running 3.3.0 and still encountering the problem, please open a new topic – I’ll close this one.

Alec Smecher
Public Knowledge Project Team