Error while trying to register doi

Hello Everyone,

I have a problem with DOI, every time i go to register a new article, one popup appears with the following error:


And when I enter the error.log to verify, this error appears:

NOTICE: Use of undefined constant Registrar - assumed ‘Registrar’ in … : assert code:1), referer: …

Can someone help me?

PS: I am sorry my english skills are bad :sweat:

THX :grin:

I assume you are running OJS 2.x. What specific version are you running? Most recent version (as of 2.4.5 or better) should provide an additional message in that error you see in the popup which better describes the specific problem.

Good morning @ctgraham

Thank you for answering, so, the version i am using is the and the only popup that appears is what I posted here.

And log erro is a NOTICE.

I forgot to say one thing, I started working with ojs a few weeks ago, so i do not know much, I did the update from 2.3.3 to and the errors with php and DOI went searching the web to solve.

Thank you in advance for your attention and help.

I’m pretty sure the rest of the error message is being masked by the untranslated error message. It should either say “No response from server” or should describe a status code and server response.

Can you try re-registering the article in a language which has a full translation, such as English? This should provide the full response. Alternately, using the “Translator” plugin, you could translate the key “plugins.importexport.crossref.register.error.mdsError”, leaving the variable {$param} as-is. That variable will be replaced by the detailed error message.

Thanks for the answer, I’ll try to do what you said and re-post here

Hi @ctgraham,

I include the line of code because I did not have it in pt_BR and when trying to register appeared a popup with this message:

A submissão não foi bem sucedida! O servidor de registro DOI retornou um erro: ‘1 - HTTP/1.1 400 Bad Request
Content-Type: application/json Vary: Accept Access-Control-Allow-Origin: * Access-Control-Allow-Headers: X-Requested-With Content-Length: 270 Server: http-kit Date: Mon, 19 Dec 2016 15:29:06 GMT X-Rate-Limit-Limit: 50 X-Rate-Limit-Interval: 1s Connection: close [:status :failed][:message-type :entity-parsing-failure][:message {:exception “com.mongodb.MongoException$DuplicateKey: insertDocument :: caused by :: 11000 E11000 duplicate key error index: crossref.deposits.$id dup key: { : ObjectId(‘5857fcc2d5dee75839dd5c18’) }”}]’.

thx for help

This is a known issue on CrossRef’s end:

Good to know that this may be it, how do I contact crossref to find out if it’s really this?


Feel free to post any update you find to this forum; multiple people are waiting on a resolution.

hi @ctgraham

What is the procedure to generate DOI manually? Where are the xml’s?


You would use the CrossRef plugin, but instead of Registering the DOIs directly, Export or Download the XML (phrasing depends on your version), then upload the results to CrossRef. Finally, mark the successfully uploaded DOIs as Registered.

The issue with the Crossref deposit API should be solved now i.e. the “Register” button should work as earlier…

Sorry for the delay in answering, the problem really was on crossref. Because it was rising manually and it was working normally.

Thank you very much for the help, you helped me a lot.

1 Like

This problem seems to have recurred at the CrossRef end. We are experiencing the very same problem as described in this thread. We have articles that were originally auto-submitted to CrossRef weeks ago, but are still marked as “Submitted” in OJS, and the DOIs/articles not showing up in CrossRef.

We’ve also tried manually loading the XML via instructions at Uploading files using the deposit system admin interface – Support Center. But all to no avail.

Has this issue recurred for anyone else?

CrossRef’s answer to the problem:
If you take a look at the error message supplied in the logs from your recent deposits, you’ll see that it begins “Error: cvc-enumeration-valid: Value ‘’ is not facet-valid with respect to enumeration…” then lists many file types and ends with “…Error: cvc-attribute.3: The value ‘’ of attribute ‘mime_type’ on element ‘resource’ is not valid with respect to its type, ‘null’.”

What all that means is that your files include a mime_type attribute with no data specified for the mime type, e.g.:

This appears twice in the deposit you provided as an example, and will necessarily cause your deposits to fail.

Because OJS is not our product, I can’t advise you as to how to modify your OJS instance or OJS/Crossref plugin to remove the empty mime_type attribute. You’ll need to contact OJS’s support team or search their community help forums for more information.

Anyone know how to 'remove the empty mime_type attribute?

Fixed the problem manually in the XML file, and manually uploaded that file to CrossRef.

The missing mime_types were related to an “interactive HTML” file that had been uploaded with one article.