Error when update to 3.1 version of ojs

#1

hi
i want to update my 3.0.0 ojs to 3.1 version
when i click on update button , It takes about 10 seconds and then get white page

i send message to my host supporter, He said this is not for timeout.
my error logs uploaded here (this is for when i click on update btn)

can you help me?

#2

Hi @amirhosein,

“Strict Standards” warnings are harmless and primarily aimed at developers. They clutter the error log, making it hard to use. You can configure strict standards error reporting in your php.ini to suppress them.

Best,
Amanda Stevens
Public Knowledge Project Team

#3

hi @astevens
I do not have access to php.ini

can you help me for update?
updater cant’t work currectly

#4

Hi @amirhosein,

You haven’t given me enough information to know why your update has not succeeded. I can only see 4 PHP errors on the screenshot that are not Strict Standards errors. Have you tried accessing your site since the update? Is it working?

Best,
Amanda Stevens
Public Knowledge Project Team

#5

hi dears
i installed 3.1 version on local and when i want to update this, see this error on php error log

[27-Nov-2017 12:51:39 Europe/Berlin] PHP Fatal error: Call to a member function getUsername() on a non-object in C:\xampp\htdocs\ojs\lib\pkp\classes\submission\SubmissionFile.inc.php on line 643

can you help me?

regurds

#6

Hi @amirhosein,

It looks like maybe your submission is assigned to a non-existent user. Have you deleted a user’s account somehow? This does not seem related to updating OJS, however.

Best,
Amanda Stevens
Public Knowledge Project Team

#7

hi @astevens

This is error on installUpgrade page

how i can resolve it?

on host , exactly happend this error

i don’t remove any user

@asmecher @ctgraham please help me
thank you

#9

Dear all
I have the same issue. Would you please help me too!!!
@amirhosein @asmecher @bozana

Previous payment transactions are missing
After upgrade OJS from 2.4.8 to 3.1 made all submission and user disappear
#10

Hi @amirhosein and the others having exactly the same error

@astevens is right – it seems that there is a file in your DB without a correct uploader user. Could you maybe double check that all your files have a uploader_user_id and that those IDs exist in the DB table users? To check if the uploader_user_id exist in the DB table users, you could maybe use this SQL statement:

SELECT * FROM submission_files WHERE uploader_user_id NOT IN (SELECT user_id FROM users)

Best,
Bozana

1 Like
#11

Thanks a lot @bozana. That was a great help
It finds 23 records that their user id were not in the users.
But why that happens?

#12

dear @bozana
thank you, i find very record widout upload_user_id exist and resolve this items by a update querry

:rose::rose::rose: