Emails don't send in OJS3.3.0-6 - SMTP ERROR: DATA END command failed

My OJS system was sending emails. I upgrade OJS from 3.3.0-3 to 3.3.0-5 and then to 3.3.0-6 but no one is working on sending emails of any type. Server in CentOS 7 and SELinux is off. I tested PHPMailer with simple php script to send email using the same account registered in and it is working. The email configuration section in is:


; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server =
smtp_port = 587

; Enable SMTP authentication
; Supported smtp_auth: ssl, tls (see PHPMailer SMTPSecure)
smtp_auth = starttls
smtp_username = ""
smtp_password = "mypassword"

; Supported smtp_authtype: RAM-MD5, LOGIN, PLAIN, XOAUTH2 (see PHPMailer AuthType)
; (Leave blank to try them in that order)
smtp_authtype = LOGIN

; The following are required for smtp_authtype = XOAUTH2 (e.g. GMail OAuth)
; (See
; smtp_oauth_provider = Google
; smtp_oauth_email =
; smtp_oauth_clientid =
; smtp_oauth_clientsecret =
; smtp_oauth_refreshtoken =

; Enable suppressing verification of SMTP certificate in PHPMailer
; Note: this is not recommended per PHPMailer documentation
smtp_suppress_cert_check = Off

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
allow_envelope_sender = On

; Default envelope sender to use if none is specified elsewhere
default_envelope_sender = ""

; Force the default envelope sender (if present)
; This is useful if setting up a site-wide no-reply address
; The reply-to field will be set with the reply-to or from address.
force_default_envelope_sender = On

; Force a DMARC compliant from header (RFC5322.From)
; If any of your users have email addresses in domains not under your control
; you may need to set this to be compliant with DMARC policies published by
; those 3rd party domains.
; Setting this will move the users address into the reply-to field and the
; from field wil be rewritten with the default_envelope_sender.
; To use this you must set force_default_enveloper_sender = On and
; default_envelope_sender must be set to a valid address in a domain you own.
force_dmarc_compliant_from = On

; The display name to use with a DMARC compliant from header
; By default the DMARC compliant from will have an empty name but this can
; be changed by adding a text here.
; You can use '%n' to insert the users name from the original from header
; and '%s' to insert the localized sitename.
dmarc_compliant_from_displayname = '%n via %s'

; Amount of time required between attempts to send non-editorial emails
; in seconds. This can be used to help prevent email relaying via OJS.
time_between_emails = 3600

; Maximum number of recipients that can be included in a single email
; (either as To:, Cc:, or Bcc: addresses) for a non-privileged user
max_recipients = 10

; If enabled, email addresses must be validated before login is possible.
require_validation = Off

; Maximum number of days before an unvalidated account expires and is deleted
validation_timeout = 14

Also, I activated the full debug for logs and I noted that smtp client conecte and authenticate successful the SMTP server, also cliento sent the email “from”, “to” and “reply-to” correctly, and the same for data email. However, comunication states with no acivity during 5 minutes and after that, the server smtp close the conection with error, as shown in figure.


Anybody can help me, please!

Hi @jlrapter

Please, review your file and double check these parameters are correctly set:

  • allow_envelope_sender = On
  • default_envelope_sender = your_address@your_host.tld
  • force_default_envelope_sender = On
  • force_dmarc_compliant_from = On

Your issue seems to be pretty close from this thread/answer:

Israel Cefrin
PKP Team

1 Like

Hello @israel.cefrin

Thanks a lot your time. The problem was fixed. The configuration of the was always good. I worked with a guy from TIC’s Assistant at my university. I don’t understand well but it seems like a default addressing of IPv6 in some routing in the network was causing the problem.
Thanks again.

1 Like

This topic was automatically closed after 6 days. New replies are no longer allowed.