Double blind review issue


#1

Some editors complain that although in the journal settings double blind is checked, when they assign a reviewer the default is blind, not double blind for review type. Current version is 3.1.1.0. Has anyone else encounter this problem?


#2

Hi @midoio,

although in the journal settings double blind is checked

Do you mean this setting?

image

Regards,
Alec Smecher
Public Knowledge Project Team


#3

I recall seeing a situation where a journal had never saved that settings page so even though it seemed that there was a default setting given there was no actual setting in the database. The settings page just showed the first option as if it would had been selected. Not sure if this is already fixed in current versions.


#4

Yes. The editors discovered that the new version of OJS does not automatically ensure a double-blind peer review even though they’ve selected this feature in the system workflow. The section editors are now required to check a box to make the review double blind when sending things out to review (which they didn’t have to do before) and some of them, not realizing this, have assigned articles to reviewers which are not blind/double blind

.


#5

Hi @midoio,

Per @ajnyga’s suggestion above, did you make sure that the setting is saved in the journal settings area where the review mode is changed?

Regards,
Alec Smecher
Public Knowledge Project Team


#6

Yes, the double blind review is saved in settings.That is the problem; when editors sent out review requests, double blind should be automatically checked, but instead, blind review is checked. Editors assumed that they would sent out double blind review requests and they were not.


#7

Hi @midoio,

Can you try running the following database query and report the results?

SELECT * FROM journal_settings WHERE setting_name='defaultReviewMode';

Regards,
Alec Smecher
Public Knowledge Project Team


#8

This is the result. Thanks!


#9

Hi @midoio,

Thanks – and what is the journal_id for the journal you’re having trouble with? (You can see this in the journals table.)

Regards,
Alec Smecher
Public Knowledge Project Team


#10

Thanks, it is journal_id # 3.


#11

Hi @midoio,

Hmm, I just ran a test under similar conditions and it works as expected – double-blind in journal setup results in a defaultReviewMode setting of 2, and the “Double Blind” option is chosen by default for new reviews (checked="checked" in the form markup). Are you having trouble with other journal settings not “sticking” when you save the setup forms? If so, is it possible that your cache directory has its file permissions set incorrectly?

Regards,
Alec Smecher
Public Knowledge Project Team


#12

Thank you very much for your help, clearing the cache solved this issue.