DOI Registration Error using CrossRef

I found the error message below and based on similar questions its seems deal with CrossRef credentials. All plugins requirements are satisfied, and I am sure credentials are correct. Please point me to the correct direction…:

Registration was not successful! The DOI registration server returned an error: '1 - HTTP/1.1 401 Unauthorized

Access-Control-Allow-Headers: X-Requested-With
Access-Control-Allow-Origin: *
Www-Authenticate: Basic realm=“restricted area”
Content-Type: text/plain
Content-Length: 13
Server: http-kit
Date: Fri, 08 Apr 2016 08:49:49 GMT
Connection: close

access denied’.

Where and when exactly do you see this error?

The message certainly points toward a credentials issue, if it is to be believed, but perhaps there is another underlying issue.

I just upgraded from to 2.4.8. It happens every time i try to hit register link (manually register) on the Unregistered Articles or All Articles. The error message appear in the small box on the right corner of the browser window.

Did you upgrade via the “Full Package” method, or via the “Patch” method? Do you have any known local modifications to your code?

I tried to register DOI only for one article for a test. But another issue I just realized come up when each DOI based on suffix pattern (1.%j.%Y.%v%i%a - not the default pattern) I filled in the Public Identifier Plugins appear below the References. Even I did not check the automatic DOI registration and did not register manually.all article has their DOI show up. Even so the DOI did not registered successfully since the related DOI link did not found in

Example in:

I did full package upgrade overwriting the previous. I did a modification on template to show the Addthis share-links.

The display of the public identifier is disconnected from the registration of the public identifier with the resolving entity. This is slightly awkward, but intentional.

For example, you could download the CrossRef XML and manually upload it to CrossRef, rather than using the built-in registration function. OJS would never know when exactly the DOI was registered with CrossRef, but it displays the DOI regardless.

That said, can you download the one article and use the same credentials embedded in OJS to manually upload to CrossRef? That might be a next best test.

1 Like

Thank you very much for the explanation Clinton.

I downloaded the CrossRef XML and successfully created DOI by uploading the XML file to CrossRef manually.
Back to the Select Article page I checked the manually registered article and hit Mark Registered button, but nothing happened to the status. Is the status related to that button Mark as Registed?
I am still expecting the auto registration to work :frowning:

Best wishes,

Yes, I would have expected the “Mark Registered” button to provide a status of some sort, but apparently this is not the case. Currently, this status constructed just with the deposit data as returned from the API.

I wonder if we could construct a crossref::depositStatusUrl setting as part of a manual “Mark Registered” and call $this->updateDepositStatus() afterwards. @jmacgreg and @bozana might know.

I’m also still curious as to why automatic registration is not working for you. Did this work prior to 2.4.8? Do you us a proxy in

I have no active proxy setting in my as well as on my network, but only port 80 is open. I never used this plugin prior to current 2.4.8 version.

This same error is also mentioned here: The problem with the DOI registration by using the plugin - #9 by bozana

There may be a broader issue with the plugin.

I encountered the same error:

Registration was not successful! The DOI registration server returned an error: ' (401 Unauthorized)'.

And it turned out to be the username. As per Crossref XML plugin for OJS - Crossref the username should be Username: Password: your Password

I missed that initially and after logging into Crossref I found the role under Users > My account. I hope this helps someone else, before performing a deep dive into the system.


This topic was automatically closed after 2 days. New replies are no longer allowed.