DOI Registration Error using CrossRef: 400 Bad Request


We are running OJS with 4 different journals. 2 of them have the plugin “DOIPubIdPlugin” activated and use the “CrossRefExportPlugin”.
DOI registration via Crossref stopped working since a few days.

We didn’t change anything to the website (besides publishing articles).
We have no active proxy setting in the file.

The problem is with all recent articles we are trying to register but also is when we try to update articles already submitted.
When we are on the “CrossRefExportPlugin” and we click on “register” or “update” via this kind of link:

We have this error message via the notification message:
Registration was not successful! The DOI registration server returned an error: '1 - HTTP/1.1 400 Bad Request
Content-Type: application/json Vary: Accept Access-Control-Allow-Origin: * Access-Control-Allow-Headers: X-Requested-With Content-Length: 270 Server: http-kit Date: Mon, 05 Dec 2016 07:36:04 GMT X-Rate-Limit-Limit: 50 X-Rate-Limit-Interval: 1s Connection: close [:status :failed][:message-type :entity-parsing-failure][:message {:exception “com.mongodb.MongoException$DuplicateKey: insertDocument :: caused by :: 11000 E11000 duplicate key error index: crossref.deposits.$id dup key: { : ObjectId(‘584518e42d0e76564955aafd’) }”}]

It talks about a duplicate key error. But I don’t know what kind of duplicate key it could be, and for an unregistered article.

The submitted link as folow works:

And we can manually upload the exported XML file at Crossref portal ( So it’s not a problem of XML document or login/password.

I don’t know what is wrong and what kind of tests I can run to check what is wrong.

Thanks in advance for your help and your answer.

We have the same problem

This same error message has been reported by multiple users:

@birkok reports contacting CrossRef, where they responded that this was not an issue on their end. This seems highly unlikely, however. Has anyone else contacted CrossRef regarding this error message?

Hi @ctgraham,
I have contacted CrossRef regarding this and replied on 2nd Dec that they are looking into it. I will update the outcome when I hear from them.



We asked Crossref too and there seems to be something with their deposit API/system and they are working on it. Till it is solved, please export XML from OJS and manual upload it on the Crossref portal. We will let you know once the issue is solve.

Any further news on this front?

Hi @tauyeung,

Yes, it should be resolved – check the other links, e.g. Manual registration of DOI in Crossref failed - #8 by salehig. It was an API problem on the CrossRef side.

Alec Smecher
Public Knowledge Project Team

Sorry for the late reply.
I confirm that it is solved for us.
Thanks for your intervention with CrossRef.