DOCX to JATS XML converter


#51

Thanks a lot @anupent
I think I did it

Any issue from the process?


#52

Hi @Vitaliy and @anupent
I have converted the docx to xml then uploaded in galley. Some issues come up

  1. When click xml, the page loads still (Loading article…)

http://jurnalbeta.ac.id/index.php/betaJTM/article/view/83/94

  1. The Reference doesn’t show

http://jurnalbeta.ac.id/index.php/betaJTM/article/view/83#title0

Here is xml file

https://drive.google.com/open?id=0B-13jpi8inZPdTRxVGIwRUdKOHc

Thanks a lot in advance for ur help


#53

Dear @kawahyu,
There is a lot of work to do even after this.

Be prepared to spend some sleepless night and keep some medicines for headache (just kidding).

Now you need to edit as required by your elens. I do not have permission for your google drive files.

Can you format your xml file’s front as in the file I have attached below? And you have to do it manually. I do not know a way to automate this.

https://mega.nz/#!VWJBSIwD!ETUyyq-eMdykSchMFfjuuH_dVS_YD7GxHxkeMAPnO-A

Regards
@anupent


#54

You are right @anupent, I have got a headache, hehe.

The Reference is solved. However, I could not have proper xml for Edited Books

http://jurnalbeta.ac.id/index.php/betaJTM/article/view/83#title5
Reference 2 and 15

Here is the xml

image

Still, xml page shows Loading article…

http://jurnalbeta.ac.id/index.php/betaJTM/article/view/83/94

Wish @Vitaliy and @anupent can give hint to solve this


#55

You need to update your elens plugin. Try downloading the latest one and retry. It will work. Here you go: https://github.com/ajnyga/lensGalley


#56

Edit your person-group for editor as
<person-group person-group-type="editor"> <name>surname and given name goes inside here </name> </person-group>

Also remove (ed.) form source and add
<edition>3</edition>

I am not sure about the latest lens viewer but I have been using one modified by @ajnyga. It helps me to upload pictures in the galley as attachment.

Edit: if you need help on any xml format, visit https://jats.nlm.nih.gov/archiving/tag-library/1.1d3/

Regards
@anupent


#57

Yep, there is a need to update eLens plugin, from @ajnygas or elifelenss repository.

Also tables after transformation need editing. td and th elements should have colspan and rowspan` attributes for proper rendering.


#58

Thanks @Vitaliy @varshilmehta @anupent
I have replace the old elens plugin through plugin/generic. But it keeps loading.
How I change table codes? to have colspan and rowspan

Here is the codes for one of the tables


#59

Your table 1 and table 2 look ok.
Your table 3 needs modification. There you need to add colspan=“2” to merge two cells columnwise to make it look good.

If you give me access to your xml file, I may see why it is not be viewed through elens

@anupent


#60

Try deleting the cache by pressing alt + f5 of the browser. See if it works
then.


#61

Hi @varshilmehta
After deleting the caches, it goes blank

Here is the xml
https://drive.google.com/open?id=0B-13jpi8inZPY3B3ZTZBd184OEk


#62

you file works fine. please see the attachment below



You should not have properly installed the elens.
Can you double check it?

@anupent


#63

According to text of your error in the browser:

Uncaught ReferenceError: translate is not defined

Try to add translation for your language here: https://github.com/ajnyga/lensGalley/tree/master/locale


#64

Hi @Vitaliy
Does add translation mean as follows:
I add folder namely id_ID and locale.xml in Plugin/Generic/LensGalley/Locale and translate some in locale like

Is there anything to do?

@anupent I deleted the previous and install it again, still same result

Thanks all for your help


#65

XML file seems to work fine. You see my previous post.
So, problem should be in the elens plugin or ??? I have no idea… clueless…

@anupent


#66

Yup @anupent
Thank you for your help. If you could check the installation I can PM the credentials for cpanel and web


#67

After replacing the files of elens, try to do the follwoing-
disable the plugin. Delete the cahe. Reload the website. Surf dor 5 mins. Re-enable the plugin. Delete the cache again.


#68

Yep.

@ajnyga has added a global variable for translating back button. Maybe problem is there (translation needed). Another option is what @varshilmehta tells you about the cache. Also ensure that you have deleted old lens files and copied new.


#69

Sorry all,
It still show a blank page
Maybe @ajnyga has the idea to resolve this

The error reported in my cpanel is as follow

[Sun Aug 06 10:17:32.714540 2017] [autoindex:error] [pid 7523] [client 188.226.165.204:58944] AH01276: Cannot serve directory /home/k2542002/public_html/: No matching DirectoryIndex (index.html.var,index.htm,index.html,index.shtml,index.xhtml,index.wml,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.js,index.jp,index.php4,index.php3,index.php,index.phtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html) found, and server-generated directory index forbidden by Options directive

Maybe it refers to blank page for xml that I open


#70

It is working on your site. You need to delete your cache of the browser and it will show on your browser as well.