defaultManuscript problem

Yes, style is my basic problem. Plugin version: 1.0.3
I use OJS 3.2.03

Hi @Gokmen_ARSLAN,

How did you install the plugin?

Regards,
Alec Smecher
Public Knowledge Project Team

I used FileZilla. I also uploaded directly to file.

Hi @Gokmen_ARSLAN,

Uploading the plugin files manually won’t register the plugin properly with OJS. The ways to properly install a plugin are

  • via the Plugin Gallery; this is the best way, as it’ll automatically make sure you’re installing the right version.
  • via the “Upload a New Plugin” tool, available to Site Administrators in the journal’s plugin settings area. Warning: you’ll need to make sure the plugin is compatible with your release of OJS, or it may break things! image
  • if all else fails, by uploading the plugin manually (e.g. via FTP) and running on the server:
    php lib/pkp/tools/installPluginVersion.php path/to/plugin/version.xml
    
    This is not recommended, though, unless you’re developing a new plugin.

Regards,
Alec Smecher
Public Knowledge Project Team

I tried and faced:
Notification
The uploaded plugin archive does not contain a folder that corresponds to the plugin name.

Hi @Gokmen_ARSLAN,

See e.g.: OJS 3.1.2 Plugin Gallery Error - Cannot Install ANY Plugin - #15 by asmecher
Also check your config.inc.php proxy settings, as recommended above.

Regards,
Alec Smecher
Public Knowledge Project Team

You mean here:

; perl (used in paracite citation parser)
perl = /usr/bin/perl

; tar (used in backup plugin, translation packaging)
tar = /bin/tar

; egrep (used in copyAccessLogFileTool)
egrep = /bin/egrep

; gzip (used in FileManager)
gzip = /bin/gzip

Hi @Gokmen_ARSLAN,

The tar setting of /bin/tar looks OK to me, though of course /bin/tar needs to exist in your server and PHP has to be allowed to execute it. (Sometimes exec is disabled, and some PHP settings like open_basedir might prevent OJS from executing things there.)

Are the file permissions in plugins subdirectories (e.g. plugins/generic) sufficient to allow OJS to create files/directories there?

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @Gokmen_ARSLAN,

I think that’s just a list of PHP modules; that’s not related to file permissions.

Regards,
Alec Smecher
Public Knowledge Project Team

I click the file and change the permission 755
Do you mean this?

Hi @Gokmen_ARSLAN,

The numeric permissions (e.g. 755) may not be enough, depending on your server setup. There are additional concerns like file ownership. It’s hard for us to give specific instructions because it’s dependent on your server configuration. See How should file permissions be set? for some details.

Regards,
Alec Smecher
Public Knowledge Project Team

I have the following error:
in /home/journalp/public_html/lib/pkp/classes/plugins/PluginHelper.inc.php on line 67

Hi @Gokmen_ARSLAN,

That’s not a complete message; there should be more in the log.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @Gokmen_ARSLAN,

The relevant message is:

[14-May-2020 00:15:08 Europe/Istanbul] PHP Warning: exec() has been disabled for security reasons in /home/journalp/public_html/lib/pkp/classes/plugins/PluginHelper.inc.php on line 67

This is what I was mentioning above. Your server administrator has disabled a function that OJS needs in order to install plugins (among other purposes); I’d suggest asking them to enable it.

Regards,
Alec Smecher
Public Knowledge Project Team

I am administrator. how can I do?

Hi @Gokmen_ARSLAN,

Look for disabled_functions in your PHP configuration.

Regards,
Alec Smecher
Public Knowledge Project Team

Do ı need to change these?
; These are paths to (optional) external binaries used in
; certain plug-ins or advanced program features.

; Using full paths to the binaries is recommended.

Hi @Gokmen_ARSLAN,

Do you mean the paths quoted in the section of config.inc.php that you posted above? Those look OK to me (and would be fine on my Debian-based machine) – but it depends on your server.

Regards,
Alec Smecher
Public Knowledge Project Team

Yes, they are.
I am checking all disabled functions but have not found anything. I still have :Notification
The uploaded plugin archive does not contain a folder that corresponds to the plugin name.
I tried to install but same error.

Hi @Gokmen_ARSLAN,

If you are still getting PHP Warning: exec() has been disabled for security reasons in your PHP logs, then you’ll definitely need to fix your PHP configuration to resolve it – there is no other solution. If you’re stuck on that, you might try looking on stackoverflow.com.

Regards,
Alec Smecher
Public Knowledge Project Team