Custom CSS disappearing from Journal style sheet

Description of issue or problem I’m having:
The custom css that we uploaded in settings>website> advanced >journal style sheet is not showing when we go to the path

Steps I took leading up to the issue:
i removed the custom css and re-added again. it shows and when i came back to the same path. its not there.
i uploaded custom css and saved it couple of times then it stays there however when i log out and log in back it disappears again

What I tried to resolve the issue:

Application Version - e.g., OJS 3.1.2:

Additional information, such as screenshots and error log messages if applicable:
Screen Shot 2022-05-12 at 12.14.22 PM

@rcgillis @NateWr is this behavior a known bug for this version?

Hi @deepakc,

Hmmm… I don’t think so, but do you have PHP error log messages that you can share? That might give a better indication of what is going on.

PKP Team

i didn’t find anything in the logs. i’ll check again today and will post them. thanks for replying

PHP Warning: chmod(): Operation not permitted in /storage/www/ee/ojs/lib/pkp/classes/file/ on line 541

whenever i tried to save the css file. it gave above message in the logs.

@rcgillis @NateWr any idea on what can be done here?

Hi @deepakc ,

That’s an issue regarding your files permissions settings.
The public_files_dir directory, as defined in, should be writeable.

1 Like

thanks for your reply. I’ll try that

where can i find this folder public_files_dir? is it public folder?

can you please elaborate more on this : The public_files_dir directory, as defined in , should be writeable.

i found public_files_dir in file but what to do here to make it writable ?

Path to the directory to store public uploaded files
(This directory should be web-accessible and the specified path
should be relative to the base OJS directory)
Windows users should use forward slashes
public_files_dir = public

The maximum allowed size in bytes of each user’s public files
directory. This is where users can upload images through the
tinymce editor to their bio. Editors can upload images for
some of the settings.
Set this to 0 to disallow such uploads.
public_user_dir_size = 5000

You need to set the public_files_dir value (public by default) to a valid path within your server.

Honestly, this will really depend on your server config. Here’s a guide for troubleshooting file permissions:

You should contact your system administrator to make it properly, as far as there could be some security policies on how to do it.


1 Like

thank you for your reply :slight_smile: !! i’ll go through them.

we simply deleted file where it was getting saved (it had wrong permissions there). after deleting from that path we uploaded it again and were able to see the file.
thank you @gonzalognzl and @rcgillis