Cannot use a scalar as an array

Hi @JCar,

You can safely delete all metaCitations rows from OJS 3.x – they’re a hold-over from OJS 2.x that is no longer useful. Execute:

 DELETE FROM journal_settings WHERE setting_name='metaCitations`;

Then remove all .php files from your cache/ subdirectory.

Alec Smecher
Public Knowledge Project Team


Hi @asmecher,
thanks for the suggestions. I did the delete all rows than you told me and all php files from cache folder, after when I tried to upload the file not show me error and nothing…


I think is upload would be ok but when I tried to search in the metrics table in ojs, not import any rows from the file.

After ran the script for importations, the log file moves from the stage folder to archive folder. I checked in the folder scheduletasklogs the log from import, and it show me than the task had sucessful files import from the processing folder, so the files moved on the correct steps and folder, maybe the error is in mysql or other step, I don’t know.

I put on the warnings before the upload but not show me nothing. Really I don’t know what is happend with the import. where is the mistake ? how can I detect what is happening with the insert rows in the mysql?

thanks in advance !

Hi @JCar,

I think the DELETE should have resolved the original issue you reported in this thread, and the issue you’re describing now is something different. Could you post that as a new thread?

Alec Smecher
Public Knowledge Project Team

thank so much @asmecher, I fixed the problem. it was because I need to set the base_url[index] and the [journals] too, after it the upload files is sucessful. sorry about the mix of topics. Really thanks

I have the same problem but ,this database did it already exist
thank you