Administration Problem


#1

I have a problem with Administration Link. I have three journals and after upgrading from 3.1.0.1 to 3.1.1.1 , I have seen some problems with upgrading Plugin (shariffPlugin.inc.php). I removed “shariffPlugin” and finally we lost “Site Administration” , “Site Management” and also “Administration Function” .
But all data for three journals are working well. We introduced these three journals Only in the first link, which show our journals as " Site Administration" .
Unfortunately, we lost this first link and we get HTTP ERROR 500 .
All three journals need to connect with their specific address only.
Please let me have your suggestion and solution to Restore “Site Administration” , "Site Management " and also “Administration Function”. Th


#2

Hi @fundasci,

How did you remove the Shariff plugin?

Can you check your PHP error log for details?

Regards,
Alec Smecher
Public Knowledge Project Team


#3

By clicking in " Installing Plugins" section.


#4

Sure. but where is exactly the place of PHP error?


#5

OK . I found it. The error are as below

22-Jun-2018 11:49:38 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_intl.dll’ - The specified module could not be found.

in Unknown on line 0

[22-Jun-2018 11:49:38 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll’ - The specified module could not be found.

in Unknown on line 0

[22-Jun-2018 11:49:39 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_intl.dll’ - The specified module could not be found.

in Unknown on line 0

[22-Jun-2018 11:49:39 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll’ - The specified module could not be found.

in Unknown on line 0

[22-Jun-2018 20:36:39 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_intl.dll’ - The specified module could not be found.

in Unknown on line 0

[22-Jun-2018 20:36:39 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll’ - The specified module could not be found.

in Unknown on line 0

[22-Jun-2018 20:36:39 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_intl.dll’ - The specified module could not be found.

in Unknown on line 0

[22-Jun-2018 20:36:39 UTC] PHP Warning: PHP Startup: Unable to load dynamic library ‘c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll’ - The specified module could not be found.

in Unknown on line 0


#6

Hi @fundasci,

Is there nothing else relevant in the PHP log? That looks like a warning to me and shouldn’t be causing the system to stop working. (It’s related to your php.ini and you can probably find some guidance on resolving it on e.g. stackoverflow.com.)

I would expect to see something else in your log related to this.

Are you sure removing the Shariff plugin was the trigger that caused the system to stop working?

Regards,
Alec Smecher
Public Knowledge Project Team


#7

I don’t know exactly because before upgrading I didn’t have any problem. I am not sure. I will try with your respected suggestion and I will check php.ini.
About your last question; really I have no idea because I was busy with updating plugins and after trying many many times finally I thought , OK . I will come back again and see what will be happen.

warm regards,
Bijan


#8

Dear Asmecher,
I couldn’t find any guide. can you help me please and what can I do for this error?


#9

What is your idea if I back to my previous version? I have the latest working Backup. If you agree, please let me know the method and the way.
How should I active the previous version with my backup file, please?
Than you.
Bijan


#10

Hi @fundasci,

A 500 error should always result in something in your log. Is it possible you’re looking at the wrong file? See e.g. How do I find my PHP error log? for some general tips; the details will depend on your server.

Regards,
Alec Smecher
Public Knowledge Project Team


#11

Dear Asmecher,
Hope you remember my problem for Administration. Unfortunately we could not solve the problem.
May I please guide me : How can Run the previous version 3.1.0.1 please?
I have my Backup. Appreciate for your step by step process.
Thank you
Bijan


#12

Hi @fundasci,

You can move back to your previous version by restoring your backups of the code, database, and files area. But I don’t recommend doing this – it’s a good practice to stay up to date.

Regards,
Alec Smecher
Public Knowledge Project Team


#13

May I please tell me Where is the location for Restoring Backups ?
Should I do from cPanel or Softaculus or …? Appreciate if tell me in simple way.
Regards
Bijan


#14

Hi @fundasci,

That depends on your host, I’m afraid – every host will be a little different. I’d suggest asking them.

Regards,
Alec Smecher
Public Knowledge Project Team