When I click some button or follow some link, I'm left with a blank page. What do I do?


Check your webserver error log

Usually, this indicates that a PHP error has occurred and the message has been sent to your web server or system log file. Check there – e.g. /var/log/apache/error.log, although the exact location will depend on your server configuration – for further details.

Check your file permissions

If you haven’t installed OJS yet, then the most likely cause is a problem with file permissions in your cache/ or cache/t_compile directories. See docs/README for information on file permissions.

Further troubleshooting

If you don’t have access to your server log file, you can try adding the following near the top of index.php to cause error messages to be sent to the browser:

ini_set('display_errors', E_ALL);

If you happen to be running in a Windows IIS environment, you may also have to enable fastcgi.impersonate=1 in your php.ini file.

You may also want to temporarily modify (approximately) line 27 of file lib/pkp/includes/functions.inc.php, removing the @ operator, so it would look like this:

if((include_once BASE_SYS_DIR.'/'.$filePath) === false) {

Remember to revert that change afterwards.

Sometimes a specific PHP script included in the software will fail to execute without any error message, e.g. due to a broken modification or a file permissions problem. To determine which script might be causing the problem, you can edit your lib/pkp/includes/functions.inc.php and find the following line:

function import($class) {

Add below it:

echo "Importing " . $class . " \n";

This will cause OJS to list class files before importing them (for ANY viewer of the site). If you are having a problem with a particular file, it will be the last one listed. Double-check the file permissions on it and try running it through the PHP linter (php -l path/to/file.inc.php).

Be sure to revert this change when you are finished.

Problems when transferring OJS from a hosting to another hosting
Configure the ORCID API
Problem Installing OJS 3.0 on SLES 12
Upgrade question
At the moment of wanting to register an article in crossref appears an error 500
ORCID iD not retrieved
Ojs create blank pages
Problem facing to Install PKP Harvester
Problem facing to Install PKP Harvester
500 Internal server- cannot update ojs
Wsod on create journal
Upgrade to 2.4.8 not working
Broken uploading image plugin
Journal Sections - error
Instalar OJS en mi pc
Website was working fine and all of sudden its not working with HTTP 500 error
Redirect to "install or upgrade page" fails
Notification new issue Bug
Need help with basic installation
Need help with installation
OJS blank page after new user registration
Published articles Pdfs cant be downloaded or viewed anymore
HOW-TO: use mod_rewrite to get rid of "?" in the url
Site Settings Page is Blank (White Page) on new installation
[SOLVED] OJS - Pages Abouts and Admin index not working after update
I have problem when i create user administration account and try install OJS?
HTTP ERROR 500 Blank Page
Error if there is an empty submission checklist in OMP 3.1
White page in html editor in Announcments
After update 2.4.6 PDF Dispalay and language
Problems with user
System plugins doesn`t work OJS
Problem to access to my manager page
After moving to another server not showing Settings - Journal - Masthead and Contact
Submission - error 500
Quicksubmit plugin shows blank page
Administration page to a multi-journal ojs 3.0.2 not loading
HTTP ERROR 500? Why is that?
Cann't set submission and citation format issue
Do not load magazines. Nor the logueo. Only charge the main
Internal Server Error only on Admin Side
OJS 2.4.8-2 to OJS 3.0.2 Beta Upgrade
Issues after update to ojs-3.0.2 (file upload, new submission not working)
Manager Plugin page remain blank
Internal server error
Page becomes empty while running menu in current conference
[SOLVED] Need some help for starting with OJS 3.0.2 and filling the database
Google.com/webmasters/tools/crawl there is server error
QuickSubmit Plugin not working
Pubmed plugin not working on ojs 3
Cannot view the pdf on the browser
[Help] OJS malfunctioning after removeing the theme folder
Problem installing OMP of MAC
Upload image in logo or cover or in upload with text error
OJS 3.0.1 and 3.0.2 new instalation problem
Submissions Unassigned
System Plugins blank page
Summary and Review Truncated
Páginas en blanco instalando el OJS / Blank pages installing OJS
Native import/export plugin-OMP
Problem in installing ojs-2.4.6
Native XML Plugin failed
[OJS3] cannot install
White (blank) page after login
New 2.4.6 install, or old install, only ever showing blank page
Native XML export
Issues with the DOI-CrossRef automatic registration
Plug-ins in OJS-2.4.8-1
Blank page installing OJS 3.0.0
Problem with Crossref Export/ Registration plugin in OJS
Error link see magazine OJS
Upgrade 2.1.1 to 2.4.8 - A database error has occurred
OCS error preventing creation of conference
Not installing: i try to install the OJS (ojs-2.4.8-1)
White Page Problem with OMP
Export issue OJS blank page
Upgrade show blank page
Upgrade from 2.4.2 to 2.4.6, Problem with plugins
OCS/ OJS Installation Problems
OMP installation problem
Ojs 2.4.8 Blank page
Unable to see published issues list ("Archive")
Bootstrap 3 theme for OJS 3
How to install OMP + Page Blank!
OJS dont't display character set in UTF-8