Validar OAI-PHM

Buenos días.

Soy el administrador del OJS de las revistas de la Universidad (https://revistas.ujat.mx, https://era.ujat.mx), al validar el OAI-PHM con https://validator.oaipmh.com/ me arroja datos que estpa bien mi OAI, pero al validar con http://oval.base-search.net/ me indica que no pasa la prueba.

Ojalá y me puedan apoyar, no se si mi OJS realmente está compartiendo meta.

Saludos a todos.

When you post your question give as much detail as possible, including the following:

  • Application Version - e.g., OJS 3.2.1.1
  • Description of issue
  • Steps you took leading up to the issue
  • What you tried to resolve the issue
  • Screenshots
  • Error log messages if applicable

You can post in any language, but please note there is a Spanish OJS forum and a German category on this forum.

Do not share any information that could compromise the security of your site or the privacy of your users.

Hola @arevalo_503 , ¿pudieras postear la imagen del resultado donde te dice que no pasa la prueba por favor? ¿qué versión de OJS estás usando?

Revisa también en tu archivo de configuración la parte de configuración OAI al parecer te falta definir algo por ahí.
https://revistas.ujat.mx/index.php/index/oai?verb=Identify

Screen Shot 2021-04-05 at 17.51.07

OAI de una de mis revistas,

Imagen del resultado en OAI-validator

Imagen de la validación con OVAL

La version del OJS es la 3.2.1.1

¿puedes validar en tu archivo config la parte de OAI que este bien definida la parte del nombre en OAI Repository identifier para cada revista? ya que en la imagen que te muesto arriba dice ojs.localhost lo cual es incorrecto.

[oai]
; Enable OAI front-end to the site
oai = On

; OAI Repository identifier
repository_id = ojs.pkp.sfu.ca (aquí debe estar tu identificador)

1 Like

Gracias por la información, voy a modificar el dato y reporto como me fue,

Comprueba también que el servidor apache anuncia el certificado SSL, pues OVAL no lo encuentra. Hemos tenido un problema similar en otro servidor OAI-PMH. Nos faltaba por definir la localización del certificado SSL y de la CA en “sslcafile” y/o en “sslcapath”

Error downloading https://www.ondarea.eus/files/AER/AER-BOTELLA-A/AER-BOTELLA-A-001.jpg: Unable to enable crypto on TCP connection www.ondarea.eus: make sure the “sslcafile” or “sslcapath” option are properly set for the environment.