Users & Roles does not load

I recently upgraded from version to 3.4.0-3. I carried out this update step by step, version by version. I didn’t get any errors. However, now when I try to access the " Users & Roles" menu, the page simply does not load. There are no errors in the php log. Any help? please

My system info is:

OS platform Linux
PHP version 8.1.25
Apache version Apache/2.4.53 (Rocky Linux) OpenSSL/3.0.7
Database driver mysql
Database server version 5.5.68-MariaDB

Hi @billtuk

Have you tried setting the item list to lower, maybe below 15?

And see if this problem still occurs.


Hi, @Muhammad_Al_Madani

Still the same

I read something about bad performance when ojs and database are on separate servers. Its correct?
Firewall is a problem?


The problem really was that the system and database were not on the same server. After putting it all together, performance increased considerably.

1 Like

Hi @billtuk,

Glad you were able to resolve this. It’s a known problem, and while we’ll be working towards improving this by decreasing the number of queries involved in assembling a page, it’s likely to take a long time due to the size of the system.

Alec Smecher
Public Knowledge Project Team

This topic was automatically closed after 14 days. New replies are no longer allowed.