Usage statistics file loader task - 5904933971a42 - Error

[2017-04-29 13:20:57] http://pkp.sfu.ca/ojs
[2017-04-29 13:20:57] [Notice] Task process started.
[2017-04-29 13:20:58] [Error] Cannot load record: submission file is not associated with a representation object.
[2017-04-29 13:20:58] [Notice] Task process stopped.

Here is the usage file: Dropbox - Error

Here is the Log File: Dropbox - Error


I recently started uploading HTML and XML format too. This happened after that only. Also, the usage file is now in the reject folder. What should i look for?

@ctgraham @bozana

Any idea what went wrong? I feel that it the HTML file which is creating the problem. Since they do not have any metrics.

Can you re-run this with show_stacktrace “On” in config.inc.php?

That should tell us which submission is causing the error and help to debug further.

To re-run the rejected file, you’ll need to move it back from the “reject” folder to the “stage” folder.

Hello, I removed the HTML files and now it is proper. Thanks

If there is a problem with metrics relating to HTML files, we will want to address it. What specific version of OJS are you using, and how exactly did you add the HTML files initially? We would like to reproduce what you saw, if possible.

Sure. I am using OJS 3.0.1. I had converted Word to HTML. Just uploaded them and the metrics just stopped.

I assume you uploaded the HTML to the “Production” tab? Did you add it as a “Production Ready File”, or as a “Galley”?

As a Galley. May be that can be a problem

There were some problems with HTML galleys and they were addressed in this issue: OJS 3.0.1: Statistics plugin needs additional testing · Issue #2134 · pkp/pkp-lib · GitHub. I think all of them are solved in OJS 3.0.2.
Best,
Bozana

Okay, so i again got an error. I dont use HTML any more. I just use XML and then embed it in the abstract page. What should I do now?

[2017-05-03 13:28:38] http://pkp.sfu.ca/ojs
[2017-05-03 13:28:38] [Notice] Task process started.
[2017-05-03 13:28:42] [Error] Cannot load record: submission file is not associated with a representation object.
[2017-05-03 13:28:44] [Error] Cannot load record: submission file is not associated with a representation object.
[2017-05-03 13:28:44] [Notice] Task process stopped.

This is what I got today. I think that this article has an error. The HTML (Abstract view isnt working only). http://jmri.org.in/index.php/jmri/article/view/62. I have changed the abstract view as HTML View. However it is abstract view. I am using Ajngya’s embed XML to HTML plugin to use embed the XML files on to the abstract. I have now activated the stack on and moved the 2 days files from the reject folder to the stage. @ctgraham @bozana But now how to re-run? It runs once per day and it has ran already for today.

This seems too confusing. What am i supposed to do?

Hi @varshilmehta

Hmmm… it seems that you have the same problem as described here: OJS 3.0.1: Statistics plugin needs additional testing · Issue #2134 · pkp/pkp-lib · GitHub It seems that the access to the dependent files like images, CSS, etc. is logged, which is wrong i.e. was a bug in OJS 3.0.1.
Would it be possible for you to upgrade to OJS 3.0.2 because those fixes are already there? – It seems that you would need several patches for OJS 3.0.1…
Also, you would need to remove those wrong URLs, that cannot be processed, from your usage statistics log files in order to then be able to reprocessed them again :frowning: Those URLs contain a number/file ID of a file that has no assoc_type = 521 (ASSOC_TYPE_REPRESENTATION).
You could maybe somehow print out the file id ($submissionFile->getFileId()) here: https://github.com/pkp/pkp-lib/blob/master/classes/statistics/PKPMetricsDAO.inc.php#L362 to figure out what URLs are wrong or take a look in your DB table submission_files where file_stage = 10 and assoc_type != 521.

Best,
Bozana

Will update to 3.0.2. I am just scared, that I will lose many modifications. Few I dont even remember.

To manage local modifications, I highly recommend version control (such as git, mercurial, or Subversion) to keep track of the changes.

With a revision control system, you know exactly what changed and why; this gives you a solid basis for keeping your personal changes in line with the latest releases from the community.

Hi @varshilmehta,

It looks like you’ve also posted this question here: Errors while upgrading to 3.0.2 from 3.0.1
Please only post each question once.

Regards,
Alec Smecher
Public Knowledge Project Team

Ok. That was because we were already talking about it over there.

I have upgraded to 3.0.2. Do I need to make any modifications further? Do I need to delete those lines in the usage stats file/folder? Or Can i Delete everything in the file itself. I wouldnt mind if few days metrics dont add up to the tally. But that would be easy right? to delete everything?

Hi @varshilmehta

Yes, you would either have to remove those lines from the appropriate/affected usage stats log files or remove those files totally. I suppose this started happening as you introduced the HTML and/or XML galleys. In the folder processing i.e. reject you would probably find the affected files.
Maybe you could take a look at those log files to se what you would lose if deleting them and if there are lots of entries there you could eventually only delete all download URLs for those articles (that have a HTML or XML galley) – in order not to search precisely for the file numbers…

Best,
Bozana

Hi all.

I am having to reprocess logs from a year ago. They were missing location data because the GeoLiteCity.dat file was missing.
I am having the same error message for all files, what can I do? What does this message really mean?
My ojs version is 3.1.1.2.

Best,
Tarcisio Pereira

Hi @bozana and @asmecher

Could you help me please?

Regards,
Tarcisio Pereira