Urdu Language Issue

Hi

I just installed OJS Version 3 and the Sub Titles in Urdu Language have been changed into Questions marks. like this ???

Please look at the articles in Screenshot. I tried to type Urdu Language in backend but didnt work. In previous version it worked fine.

image

Hi @a2usmani,

Double-check your character set and collation settings in config.inc.php, and make sure you created the database with the right default character set (typically UTF8).

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher
I checked as you said. Here are the settings I found in the file

; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

; Database connection character set
; Must be set to “Off” if not supported by the database server
; If enabled, must be the same character set as “client_charset”
; (although the actual name may differ slightly depending on the server)
connection_charset = utf8

Now please guide what to do?

The configuration settings look correct, but the database may still have a different character set and collation. You can check these by running the following SQL query on your database (replace db_name with your database name):

SELECT DEFAULT_CHARACTER_SET_NAME, DEFAULT_COLLATION_NAME
FROM INFORMATION_SCHEMA.SCHEMATA WHERE SCHEMA_NAME = 'db_name';

asdasd

I got this on running the query. Please guide next

Thankyou

@NateWr @asmecher Please see the above post.

Hi @a2usmani,

The latin1_swedish_ci result is a problem; it should be UTF8. This is usually set when you create your database, e.g.:

CREATE DATABASE my_database_name DEFAULT CHARACTER SET utf8;

Do you know how the default character set was configured before you ran your upgrade? (You can check this in a database dump by looking at the CREATE TABLE statements, if you have a backup taken before you ran the upgrade.)

Regards,
Alec Smecher
Public Knowledge Project Team

Now when I tried to change it. There was no change and also it returned an error that I dont remember right now.