Update 2.4.8 to - Error: Row with id developedbyblockplugin not found!

Hello Everybody:

when I activate / deactivate custom block plugin I get:


the plugin is not shown on the web. Similar to other plugin

Language Toggle Block: activate but not shown on the right The option to change the language

what is the potential


Hi @cristianviza,

Are you using MySQL or PostgreSQL?

Alec Smecher
Public Knowledge Project Team


When a plugin is activated, the error is displayed.
The problem is that they are not listed.

Fig 1:

Hi @cristianviza,

There are two things happening here:

  1. I think you have outdated CSS in your cache directory. Try removing any CSS files from there; they should be re-generated when needed.

  2. You’re hitting this PostgreSQL-specific bug and need to run in your DB: UPDATE plugin_settings SET setting_value=1 WHERE setting_name='context' AND LOWER(plugin_name) LIKE '%blockplugin';
    Then flush your data cache (rm -f cache/*.php).

Alec Smecher
Public Knowledge Project Team

Solved ed with 2.

Thanks :slight_smile:

Buenas tardes, tengo el mismo problema, aunque el sitio a sido vulnerado, borré las carpetas y archivos extraños y actualicé a la version 3.2.0-3. Luego de ejecutar el script sql y la eliminación de los archivos de la cache como lo indicó por el problema de error de blockplugin. No solucioné el problema y ademas a cada rato me sale que se produjo un error inseperado. Espero su respuesta. Saludos
Marcela Maurell

Hi @marcemaurell,

It looks like you’ve already solved this problem over here. Please don’t post the same problem in multiple places – it clutters the forum.

Alec Smecher
Public Knowledge Project Team