Unknown column 'public_access' - OMP 3.x


#1

Hi,
I am running OMP 3.1.1.0. When I try to add a file to the “Submission Library” area, the file seems to upload fine (goes to 100% and then a green check mark), but when I click OK, it hangs. I checked the apache log file and noticed this database error:
omp: DB Error: Unknown column ‘public_access’ in ‘field list’, referer: htt…
I verified the database was updated as well. Any thoughts on how to resolve this issue?
Thanks,

  • Jim

#2

It would be great if someone could at least point me in the correct direction on this.


#3

Hi @jbutler,

Did you recently upgrade to OMP 3.1.1.0? What version did you upgrade from?

Thanks,
Amanda Stevens
Public Knowledge Project Team


#4

Thanks for the reply @astevens. We upgraded in May from 3.1.0.0. I’m unsure if this was an issue in the previous version since I don’t believe they were trying to upload files to the Submission Library in the past. Any advice would be appreciated.


#5

Hi @jbutler,

Thanks for the further information. One thing that changed between OMP 3.1.0 and 3.1.1 is that files uploaded to the Submission Library can be marked as public access, per the attached image. Do you see this option on your site when you upload a file? I wonder if something was missed during the upgrade.

Thanks,
Amanda Stevens
Public Knowledge Project Team


#6

Thanks @astevens,
Sorry, it’s taken me a while to get another upgrade window. I wanted to make sure I did a clean upgrade before bugging you again. Thanks for the screen shot, I can confirm I do not have the public access option in that window. I just upgraded OMP to 3.1.1.4 from 3.1.1.0 and I was hoping it would resolve this issue, unfortunately not. The database upgrade went fine.
It’s seems the adding of the public_access field happened in an earlier version upgrade, so I can see why it still didn’t work this time. Do you have a recommendation of how to get passed this issue? Any help would be greatly appreciated.
Thanks Amanda,
Jim


#7

Hi @jbutler,

I’m sorry, I made a mistake in my last message. It was the Publisher Library that acquired the public access option, not the Submission Library. So you should not see the public access option when you upload a file to the Submission Library. Are you still seeing the error message when you upload a file to the Library since you did your latest upgrade?

Thanks,
Amanda Stevens
Public Knowledge Project Team


#8

Hi Amanda - @astevens,
Thanks for following up. So the process of uploading is fine, it gets to 100% and I see a green check mark. The issue is after I click ok, it sits in a loading state. Rotating circle, highlighted in the screen shot. I still get the same error as before in the php log file: DB Error: Unknown column ‘public_access’ in ‘field list’
Any thoughts?
Thanks for the help.


#9

Hi @jbutler,

Are you absolutely sure that you got a “success” message when you ran the upgrade? What version does OJS self-report if you go into Site Administration?

Do you see the following lines in lib/pkp/xml/schema/libraryFiles.xml?

<field name="public_access" type="I1">
    <DEFAULT VALUE="0"/>
</field>

Regards,
Alec Smecher
Public Knowledge Project Team