Unable to install plugin

When I tried to install the new plugin there is an error
“The uploaded plugin archive does not contain a folder that corresponds to the plugin name.”
Please guide me on how to fix it? I am using the latest version of OJS

Hello @editor.pij,

Can you provide a few more details, please? Which plugin are you attempting to install and where did you obtain it (provide links, please)?

All plugins have the same issue when I tried to install from gellery.

That error message appears when the plugin package that you have uploaded is not named correctly or does not contain the expected files. You will need to provide us with more details about the plugin you are trying to upload. Can you please provide more details and a screenshot of the entire screen.

All of the plugins in the gallery facing the same issue.

Hmm, that sounds like maybe you have a server configuration issue. The plugin gallery install packages are all tested to ensure they’re formatted correctly. Perhaps you’re running into a file permissions problem that is preventing the package from being downloaded or something.

Please guide me how to fix this issue

I recommend that you reach out to the technical support that’s available to you (like your hosting or service provider) for help identifying the source of the problem.