Unable to deselect Volume, number and years in issue data section

Hi guys,

I am using version 3.0.2. I am facing an issue with regards to the issue management of the back issues. I want to hide the volume, number and years while displaying the archives. But even after going to the edit section of any article and deselecting the volume, number and years, it doesn’t seem to work. I updated the code as shown in the following link : Show volume info only when checkbox selected · Issue #1907 · pkp/pkp-lib · GitHub. But it didn’t seem to fix it.

Kindly help.


You seem to have a custom theme in use? I would guess that the themeplugin has a custom issue template and showing the volume and number is maybe handled there?

Hi Ajynyga,

I am not using a customer Theme plugin. I have used a custom css to change the styling of navbar and background image. I don’t think it handles the volume and number in any way.


But you have the user navigation link in the navbar (admin 0). Do you mean that you moved it from the upper right corner to the same place with the navigation bar only using CSS? I mean it is of course possible, but that led me to think that you have a custom theme.

What is you base theme? Do you use the default theme?

Sorry I forgot about that change.
Yes I moved it from upper right. I appended a new id to the navigation which was used for styling.Could that have affected the volume, years and number selection ?
Yes, I am using default theme.

Ok, but if that is the only template change you did, it should not affect this.

I think that this is at least wrong, it should check for $issueSerie

But even with that change the three 0 values keep coming.

That is because the issue_summary template calls for this function https://github.com/pkp/ojs/blob/master/classes/issue/Issue.inc.php#L506 AND sets the showtitle attribute to false.

So, when this function is called https://github.com/pkp/ojs/blob/master/classes/issue/Issue.inc.php#L440 all the checks here return nothing https://github.com/pkp/ojs/blob/master/classes/issue/Issue.inc.php#L467-L483

And this option is then chosen as default https://github.com/pkp/ojs/blob/master/classes/issue/Issue.inc.php#L485
Leading to the Vol 0 No 0 (0) output you got there.

@asmecher, this is a clear bug. What are the situation where the line 485 override is needed?

Hi ajnyga, Do i need to edit $issueTitle to $issueSeries / $issueSerie. I have edited to $issueSeries and refreshed the page. But even after making the changes, I can see the volume in the article summary whereas the option was unselected for that specific article.

There is a bug in the function https://github.com/pkp/ojs/blob/master/classes/issue/Issue.inc.php#L440

There are many ways of fixing this, so better wait for @asmecher’s comments.

I believe that here is the problem in the issue_summary.tp: it calls getIssueSeries in every case, which looks for the settings other than showTitle and because there is none it creates the default. Thus, I believe the identification in this template should be handled differently – the showVol, showNum and showYear should be considered i.e. only issueIdentification…


That would solve the problem in this particular template, but if getIssueSeries function is used somewhere else without similar checks, the problem will return.

Is there any update on this @ajnyga and @asmecher?