Trying to upgrade from 3.1.1 to 3.2.0.0 but facing this error

Error is - A database error has occurred: Unknown column ‘agm.style_file_id’ in ‘where clause’

Screenshot 2021-07-21 at 21-23-39 Upgrade Open Journal Systems

Hi @Altechmind_Official

This issue looks similar to this one regarding upgrades using PostgreSQL:

Could you please have a look in the solution proposed?

Best,
Israel Cefrin
PKP Team

Hi,

But I tried adding that patch too on the website and tried, but no luck. Same problem.

Also I am using MySQL database.

Hi,

Please help me to fix it.

Hi @Altechmind_Official

Is the install returning the same error message? What happens when you attempt to run the upgrade process?

Best,
Israel

Yes, i have tried to fresh upgrade by using, but found same error everytime!