Translate plagin and Access denied

ojs3

#1

Dear OJS Team,
I have problem with Translation plugin
When i try to translate one of xml. It show me the error “Access denied”
In version OJS 3.1.1-2 it works great, but in 3.1.1-4 it doesn’t


What i need to do?


#2

Hi @Oleksandr_Radkevych,

Are you running the most recent release of the translator plugin? If not, I’d suggest updating it to the newest (2.0.2).

Regards,
Alec Smecher
Public Knowledge Project Team


#3

I have the same problem but I have the last version of OJS and translator

some idea?


#4

We’re seeing the same thing after updating from 3.1.1-2 to 3.1.1-4.

The translator plugin is the version tagged as ojs-3_1_1-4 (1e24744f9).


#5

Hi guys, I have same problem with lastest version ojs and translator plugin after setup today.
Do we have any update for this? I don’t know what i need to do.

Thanks,
Minh


#6

Here is the php errorlog. We are currently using OJS 3.1.1.4 and the Translator Plugin 2.0.2.2 if this helps. PHP version is 7.0.32.

[24-Sep-2018 15:29:54 CST6CDT] PHP Deprecated: Non-static method TranslatorAction::getLocaleFiles() should not be called statically in /home/***/plugins/generic/translator/controllers/grid/LocaleFileGridHandler.inc.php on line 36
[24-Sep-2018 15:29:54 CST6CDT] PHP Deprecated: Non-static method TranslatorAction::getEmailFileMap() should not be called statically in /home/***/plugins/generic/translator/controllers/grid/EmailGridHandler.inc.php on line 187
[24-Sep-2018 15:29:54 CST6CDT] PHP Deprecated: Non-static method TranslatorAction::getMiscLocaleFiles() should not be called statically in /home/***/plugins/generic/translator/controllers/grid/MiscTranslationFileGridHandler.inc.php on line 35
[24-Sep-2018 15:30:59 CST6CDT] PHP Deprecated: Non-static method TranslatorAction::getLocaleFiles() should not be called statically in /home/upra3613/ojs.upra.org/plugins/generic/translator/controllers/grid/LocaleFileGridHandler.inc.php on line 160
[24-Sep-2018 15:31:51 CST6CDT] PHP Deprecated: Non-static method TranslatorAction::getLocaleFiles() should not be called statically in /home/***/plugins/generic/translator/controllers/grid/LocaleFileGridHandler.inc.php on line 36
[24-Sep-2018 15:31:55 CST6CDT] PHP Deprecated: Non-static method TranslatorAction::getLocaleFiles() should not be called statically in /home/***/plugins/generic/translator/controllers/grid/LocaleFileGridHandler.inc.php on line 36


#7

I have similar problem with that plugin. I started topic here:


#8

After successful upgrade of Translator plugin I tried to edit translations but I got message that Access is denied.
Please advise


#9

Hi @vvucic,

I’ve released version 2.0.3 of the translator plugin to address this. See https://github.com/pkp/translator/releases/tag/v2.0.3-0 (or better yet, try upgrading the plugin from the plugin gallery as Site Administrator).

Regards,
Alec Smecher
Public Knowledge Project Team


#10

I entered xml file after upgrade. made change and change is saved. This is very promising for now. :smile:


#11

It is working well, thank you