There are no role for Layout Editors, Copyeditors, and Proofreaders

Dear all,

I was using ojs version, and I just realized that in my ojs I don’t have role for Layout Editors, Copyeditors, and Proofreaders. An then, just now I upgraded my ojs to version, but turns out those three roles are not available. Please help what should I do to have those 3 roles?



Hi @eddhie,

The default setting of the journal is that the editor will undertake these roles. You will need to enable both these roles within your journal settings by going to Journal Management > Journal Setup > Management.


Once you enable both of these, the roles should appear back on your list.

Kind Regards,
Patricia M.
Public Knowledge Project Team