The language of the list of countries does not change in any form [OPS]

Dear all,

In the user registration form and contributor registration form, the country name is displayed in English in the pull-down menu for selecting the country name.
The English country name is displayed on both the Japanese page and the English page any time.

I’ve read similar articles in the past (3 points below), but no matter what I do, I can’t solve the problem. 67121

My environment OS is Ubuntu 20.04, and the locale setting of OPS ( is Japanese (ja_JP.UTF-8) as the primary locale and English (en_US.UTF-8) as the secondary locale.

The following is added to registry/locales.xml.
<locale key="ja_JP" complete="true" name="Japanese" iso639-2b="jpn" iso639-3="jpn" />

In, “locale=ja_JP” is set.

Default locale; Default locale
; locale = en_US
locale = ja_JP

Also, when I created and executed the following script, “日本” is displayed without any problem.

$locale = 'ja_JP';

putenv('LANGUAGE=' . $locale . '.UTF-8');
putenv('LC_ALL=' . $locale . '.UTF-8');
setlocale(LC_ALL, $locale . '.UTF-8');

$isoCodes = new \Sokil\IsoCodes\IsoCodesFactory();
$countries = $isoCodes->getCountries();

echo $countries->getByAlpha2('JP')->getLocalName() . "\n";

By the way, on AWS AmazonLinux2 (OPS settings are all the same as Ubuntu), the Japanese country name is displayed in Japanese on the Japanese page, and the country name is displayed in English on the English page without any problem.

In addition, the default locale is “ja_JP.UTF-8” for both Ubuntu / Amazon Linux2.

# cat /etc/default/locale
LANG = ja_JP.UTF-8
LC_ALL = ja_JP.UTF-8

What else should I check? I would appreciate it if you could teach me.

Thanks in advance.

After executing the following command, restarting Ubuntu and apache2 solved the problem.
“# update-locale LC_ALL = ja_JP.UTF-8”