The current role does not have access to this operation (JM)

I’m trying to figure out why this error is coming up for the Journal Manager role. We are testing out the upgrade path from an older 2.4 version. The upgrade seems to have worked however in putting in some test cases everything seems to be completely messed up.

I have 2 submissions which are stopped dead because the journal manager cannot access these submissions. They cannot even view them. Both items are currently assigned to the journal manager and if I go in with a different journal manager account I can access them.

If I try to remove the assignment, reapprove the submission and reassign through a 2nd journal manager account the original journal manager can still not get access to the submissions.

Everything seemed to get hung up as soon as we tried to go from the review step to the copy editor step. Up to that point it all seemed to be working okay.

I see that other people have had similar problems on other role types but the other instances don’t seem to be similar to what we are experiencing here.

Any help in figuring this out would be appreciated.

Hi @Kevin_Feenan

Hmmm… Could you try to reproduce the problem while watching in the server PHP error log file, e.g. to access that submission as the JM that has problems. Do you see any errors in the log file?
Could you do the same when going from the review to the copyediting step?
Could you then report what exactly you have tried to do and any errors that you have received.

Also, was you upgrade successfully finished without any warnings (in the command line or error log files)?

Best,
Bozana