Supporting agencies not in metadata form OJS 3.2

Hello dear friends,

Supporting agencies field doesn’t appear on metadata form in OJS 3.2 even after enable it
It was withdrawn from submissionMetadataFormFields.tpl.

Please could you check it?

Hi @lcmartinezru,

See Supporting Agencies field does not display in editorial metadata form · Issue #5628 · pkp/pkp-lib · GitHub for details and a fix.

Alec Smecher
Public Knowledge Project Team

Thank you Asmecher,

I have applied the changes but the field still doesn’t show in metadata.
We have also to add it in templates/submission/submissionMetadataFormFields.tpl but doesn’t show either.

Best regards,

Hi @lcmartinezru,

Did you make the changes manually, or apply the patch file? What changes did you make in templates/submission/submissionMetadataFormFields.tpl?

Alec Smecher
Public Knowledge Project Team

Hello, yes I made the changes manually

In that file:

line 18:

$languagesEnabled || $subjectsEnabled || $keywordsEnabled || $agenciesEnabled || $citationsEnabled || $disciplinesEnabled}

line 48:

{if $languagesEnabled || $subjectsEnabled || $keywordsEnabled || $agenciesEnabled || $citationsEnabled || $disciplinesEnabled}

Added lines 68 to 72:

{if $agenciesEnabled}
	{fbvFormSection label="submission.supportingAgencies" required=$agenciesRequired}
		{fbvElement type="keyword" id="agencies" multilingual=true current=$agencies disabled=$readOnly required=$agenciesRequired}

Sorry, but I don’t know how to add as code here,
Best regards

Hi @lcmartinezru,

I don’t think those are the right changes. Did you see the link to pkp/pkp-lib#5628 Fix supporting agencies field display · pkp/pkp-lib@e90e115 · GitHub?

Alec Smecher
Public Knowledge Project Team

Hi asmecher,

Well, I only changed the 3 lines in those 3 files, I didn’t check other commits that those files already have.
I’m checking it again and the field is shown after making both changes, changes from the commit and the changes I wrote above.

I got those changes from a past version of the file but I don’t really know the reason you removed/changed that lines in the past.


Hi all,

I am using OJS and I can see the Supporting Agency fields on the metadata editing form, but can’t get it visible among the article metadata.

Actually, I also have some supplementary files in articles published under version and now I can’t reach those neither. Is there any way to get that data visible with articles in archive?


Hi @apapyn,

This may have already been resolved in a later release. I’d suggest checking the test drive installation to see whether the same issue appears there; if not, you might consider upgrading.

Alec Smecher
Public Knowledge Project Team

Dear @asmecher ,

Could you please kindly validate if Supporting Agencies metadata is working in the latest issues.

I have upgraded to and still can’t get this metadata visible on the frontend, though can see that it has been saved to DB.

Problem solved?
The same behavior in version 3.3.0-6.
Still can’t get this metadata visible on the frontend

Hi @cferreira,

You’re right, this particular piece of metadata is not made visible on the front end. There is an open issue discussing this here: Display additional submission metadata on article landing page · Issue #3294 · pkp/pkp-lib · GitHub

I’m not sure where this stands currently, however - I will follow-up with our dev team to see if they can weigh in on the implementation of this.

PKP Team


I have discussed this with one of our development team members, and, as I noted in referring to the Github issue, this issue is on our radar, but has not been able to be prioritized for development to be included in a release. Capturing the data for fields like supporting agency is important and may be included in other utilities such as import/export plugins, but getting it (and other related metadata) to display publicly on the article page is not something that has been done yet. You can watch the Github issue for any further progress on this issue.

PKP Team

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.