Support url doi in OJS v3


I have detected that one of the published articles does not show the DOI url. I access the control panel, I access this published article and I access the section Metadata of sending and publication / Identifiers and I see that the url is assigned.

What can it be because it only happens in this article?

Thank you and I look forward to your response.

Hello, does anyone have knowledge of what may be due? Thank you!

What version of OJS3 are you using?

Does the identifier tab have a red button visible?




What about the second question?

Where should I go, could you tell me the route and / or a sample capture? Thank you and I am waiting, since I do not understand your answer.

Access the submission > Metadata > Identifiers

It has the save button (in gray) and a cancel button (in pink)

Does it have a red button that says “Clear DOI”? Like this:


That button does not appear to me. Just save and cancel.

Then the article does not have a DOI assigned.

Go to the same tab and click save with the checkbox checked.

It has the DOI assigned because it appears in the identifiers section. Where the “Assign a DOI to this article” check box is selected. I await your response.

do you see a text that says “What you see is a preview of the DOI. Select the checkbox and save the form to assign the DOI.”?

This is what it looks like when the DOI is not assigned:


Indeed, that same picture appears to me. What should I do? Since the article is already published. Thank you and I am waiting.

click save, that will assign the DOI

Correct, the problem I had is that I did not save a second time, which is when the button appears. Thanks for everything @ajnyga.

Hello everybody,

If I don’t want to assign DOI, what should be done? I uncheck “Assign the DOI to this article” and save but when I go back to the “identifiers” tab it is checked. Is it a plugin bug?

Regards and thank you very much