Submissions "All active" tab stuck on loading - SOLVED

We have just started using OJS 3.0.2, and have a number of submissions pending. However, some have been reviewed, and should listed in the all active tab.

However, the All Active is stuck loading the list. Different browsers have the same issue.

How can i resolve this?



EDIT: it seems that fetch-grid is returning an error status 500

EDIT 2: I have deleted some records, and this solves the problem. Re-importing these records from ‘submissions’ brings up the problem again
I cannot see any differences between the records. I can attach these records, but I am not sure if it is the submissions table is important or something else

EDIT 3: error log in PHP shows:
PHP Fatal error: Call to a member function getInitials() on null in /home3/ssciberras/public_html/lib/pkp/controllers/grid/submissions/ on line 82

this is the function below:
function getCellActions($request, $row, $column, $position = GRID_ACTION_POSITION_DEFAULT) {
$submission = $row->getData();
$user = $request->getUser();
switch ($column->getId()) {
case ‘editor’:
$stageAssignmentDao = DAORegistry::getDAO(‘StageAssignmentDAO’); /* @var $stageAssignmentDao StageAssignmentDAO /
$editorAssignments = $stageAssignmentDao->getEditorsAssignedToStage($submission->getId(), $submission->getStageId());
$assignment = current($editorAssignments);
if (!$assignment) return array();
$userDao = DAORegistry::getDAO(‘UserDAO’); /
@var $userDao UserDAO */
$editor = $userDao->getById($assignment->getUserId());

			return array(new LinkAction('editor', new NullAction(), $editor->getInitials(), null, $editor->getFullName()));
		case 'stage':
			$stageId = $submission->getStageId();
			$stage = null;

			if ($submission->getSubmissionProgress() > 0) {
				// Submission process not completed.
				$stage = __('submissions.incomplete');
			switch ($submission->getStatus()) {
					$stage = __('submission.status.declined');
					$stage = __('submission.status.published');

with line 82 being:
return array(new LinkAction(‘editor’, new NullAction(), $editor->getInitials(), null, $editor->getFullName()));

This is due to a problem we had with the DM - I had deleted the user which happened to be an editor, in order t orecreate

Just goes to prove that one should not touch the Databases directly, it seems


OJS 3.0.2
I’m facing the same issue, same error, but I didn’t delete or remove any editor from the database. Or at least that I’m aware of.
How did you solve it? From what i understood you knew what to recreate.

Thank you!
Best regards

How did you solve this problem? as I am facing the same problem actually I deleted the user directly from databases which was editor.