Submission Unassigned, Archive, All Active not functioning

OJS 3.2.o.1

When I click the submission tab, first of all it shows the following:
52%20PM

Then when I click the Unassigned, Archive and All Active tabs, it just keeps on loading as shown below:
33%20PM

This is shown in the developer tool:
24%20PM

the lin 315 in the error shows this:
this.options.title+""):b.append(’

’);this.options.canClose&&b.append(’’+this.options.closeButtonText+"");b.append(’
’);b.attr(“role”,“dialog”).attr(“aria-label”,this.options.title);return b};a.pkp.controllers.modal.ModalHandler.prototype.modalOpen=function(b){a(“body”).append(b);setTimeout(function(){b.addClass(“is_visible”)},10);setTimeout(function(){b.focus()},

Please help

Hi @Altaf_Bankotkar,

Check your PHP error log for details.

Regards,
Alec Smecher
Public Knowledge Project Team

my PHP error log is not updating. why so?

Hi @Altaf_Bankotkar,

Do you mean that you’re not encountering anything new in the PHP error log? Then it’s possible that there isn’t a server-side problem. You can verify by looking at the “Network” tab to see what the requests that correspond to the lists look like – if the server is responding with a 200 code (OK) or a 400 or 500 or something that would indicate an error condition.

Regards,
Alec Smecher
Public Knowledge Project Team

Sorry for my inadequate knowledge. where do I find Network tab?

Hi @Altaf_Bankotkar,

You can see it on the screenshot of your browser’s developer tools, in the list of tabs.

Regards,
Alec Smecher
Public Knowledge Project Team

ya it shows 404 not found …
40%20PM
why has my PHP error suddenly stopped working? no error is being displayed since yesterday…

before that i had uploaded a php.ini file… is it cos of that?

Hi @Altaf_Bankotkar,

This is the same problem you were encountering before with the disable_path_info setting turned to On. You’ll need to turn that setting Off and work with your server configuration as documented in the other thread: Jounal not being created - #17 by asmecher

Regards,
Alec Smecher
Public Knowledge Project Team

So I did the following steps:

append a new line into existing php.ini:

auto_prepend_file = set_path_info.php

Add a new file in OJS root folder set_path_info.php:

<?php
if (getenv('ORIG_PATH_INFO')) {
    putenv("PATH_INFO=".getenv('ORIG_PATH_INFO'));
}
if ($_SERVER['ORIG_PATH_INFO']) {
    $_SERVER['PATH_INFO'] = $_SERVER['ORIG_PATH_INFO'];
}
if ($_ENV['ORIG_PATH_INFO']) {
    $_ENV['PATH_INFO'] = $_ENV['ORIG_PATH_INFO'];
}
?>

Added the same .htaccess file (as suggested by twa here) in the OJS folder.

Then I set disable_path_info = Off in config.inc.php.

when I run test.php here’s what it shows:
52%20PM

When I enter my website it shows this:
10%20PM

Anything wrong I did?

P.S: The Notice (before the error ) shows because I turned display_errors = On in php.ini file

Hi @Altaf_Bankotkar,

The code the user suggested may cause warnings like this. A slightly improved version would be

<?php
if (getenv('ORIG_PATH_INFO')) {
    putenv("PATH_INFO=".getenv('ORIG_PATH_INFO'));
}
if (isset($_SERVER['ORIG_PATH_INFO'])) {
    $_SERVER['PATH_INFO'] = $_SERVER['ORIG_PATH_INFO'];
}
if (isset($_ENV['ORIG_PATH_INFO'])) {
    $_ENV['PATH_INFO'] = $_ENV['ORIG_PATH_INFO'];
}

This should at least correct the warning.

Regards,
Alec Smecher
Public Knowledge Project Team

Thanks. Now with the disable_path_info = Off in config.inc.php, the page shows the same 404 Not Found
However, when I turn it on, it shows a slightly different error:
56%20PM

Hi @Altaf_Bankotkar,

You’ll definitely need to leave the disable_path_info option Off.

If you’re still getting a 404 error, and you’re using mod_rewrite to remove the index.php from the URL, I’d suggest turning off your rewrite rules until you’ve got the basics working without disable_path_info.

Regards,
Alec Smecher
Public Knowledge Project Team

1 Like

When I turned disable_path_info option On, the submission tab opened without any errors, on its own. Did you guys do something? No pop-up error, and all Unassigned , Archive and All Active tabs, are working fine. :neutral_face:
I didn’t change anything at all

hello @asmecher,i know its been a while since this topic got any deliberation but i couldn’t help but notice that i had i encountered a similar problem as @Altaf_Bankotkar but my problem occurs specifically when i try to assign a submission to an issue, when i press the “assign to issue” button i get a "403 forbidden " error logged to the console, so i realised his solution would not solve my problem. I did a little digging and found out it might have something to do with modsecurity as can be seen in this forum [OJS 3.1.0-1] issue to submit metadata saveStep/3 403 (Forbidden), i’m not php savvy, so i might not understand exactly how to go about setting this feature off on my own or if i should even set it off at all…any help from you would be greatly appreciated.

RECAP
under submissions>>view>>publication>>issue>>assign to issue>>save

once i select the submisson and click "save"i get a 403 error on the console and a “requested URL not recognized” popup like below (error message highlighted in yellow)

ojs 403 error 3

and the network tab shows nothing,please help me with a practical way of solving this…i have little experience with php, thank you sir

Hi @simon_ushie,

Can you please create a new post describing your issue (and link back to this post if it’s related to your issue)? And, please include your OJS version in your post. This will create help keep the forum better organized.

Best regards,

Roger
PKP Team