Some sections appear blank after an update from 3.2.1-4 version to 3.3.0-10

Description of issue or problem I’m having:
The “journal” and “administration” sections are left blank.

Steps I took leading up to the issue:
I ran an upgrade from 3.2.1-4 to 3.3.0-10 using the web interface.

What I tried to resolve the issue:

Application Version - e.g., OJS 3.1.2:
OJS 3.2.1-4

Additional information, such as screenshots and error log messages if applicable:

Hello @Sunny,

Have you checked your PHP error logs? Perhaps these provide some clues as to what is going on here?

PKP Team

Well, I had a backup and restored everything…
So this time I tried to upgrade to version 3.3.0-10 again and when I ran php tools/upgrade.php check, informed me this:

PHP Fatal error: Uncaught RuntimeException: Error creating resource: [message] fopen( failed to open stream: Unable to find the socket transport “http” - did you forget to enable it when you configured PHP?
[file] /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php
[line] 324 in /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php:253
Stack trace:
#0 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php(335): GuzzleHttp\Handler\StreamHandler->createResource()
#1 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php(52): GuzzleHttp\Handler\StreamHandler->createStream()
#2 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php(37): GuzzleHttp\Handler\StreamHandler->__invoke()
#3 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Middleware.php(29): GuzzleHttp\PrepareBodyMiddleware->__invoke()
#4 /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/s in /opt/revistas/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php on line 52

Hi @Sunny,

Double-check that the [proxy] section of your configuration file is correctly configured. See e.g. this suggestion, recommending the use of tcp:// for proxy URLs in place of http.

Alec Smecher
Public Knowledge Project Team

Hmm I didn’t get to try the tcp thing (which I don’t doubt will work) but also installing the curl module for php solved the problem.
apt install php-curl
Thank you very much!!!

1 Like

My proxy is disabled and ojs show the same behaviour. I changed session_check_ip to Off but no success.
Which file or table store IP numbers so I can delete those?

Hi @rodrigocamargos,

I suspect you’re probably encountering a different problem, but you can confirm by looking at your PHP error log.

Alec Smecher
Public Knowledge Project Team

Hi asmecher
As was mentioned by Sunny, I installed the curl module for php and solved the problem.
Thank you!

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.