[SOLVED] Tinymce doesn't work after upgrade to ojs 3.1.2

Hi all.

I just upgraded the system to OJS 3.1.1 to the latest version, I had to remove the plugin “informationBlock” because it crashed during the database upgrade.

The upgrade process then went well and we haven’t lost any information from the database. I have also noticed that the TinyMCE doesn’t appear anymore on the admin area, basically I can’t edit the website contents anymore. The TinyMCE plugin is installed correctly.

The only error I see in the error log is [Thu Jul 04 15:14:07.105963 2019] [php7:error] [pid 22318] [client] PHP Fatal error: Uncaught Error: Call to a member function getId() on null in /var/www/ojs/plugins/generic/webFeed/WebFeedBlockPlugin.inc.php:93\nStack trace:\n#0 /var/www/ojs/lib/pkp/classes/plugins/BlockPlugin.inc.php(177): WebFeedBlockPlugin->getContents(Object(Smarty_Internal_Template), Object(Request))\n#1 /var/www/ojs/lib/pkp/classes/plugins/HookRegistry.inc.php(107): BlockPlugin->callback('Templates::Comm...', Array)\n#2 /var/www/ojs/lib/pkp/classes/template/PKPTemplateManager.inc.php(1116): HookRegistry::call('Templates::Comm...', Array)\n#3 /var/www/ojs/cache/t_compile/65bfc3e024c2e9104f46e23b73376a9455e3df0e^4dffb64063bb972c37e05619a2ccd9d0ea7473ac_0.app.frontendcomponentsfooter..php(29): PKPTemplateManager->smartyCallHook(Array, Object(Smarty_Internal_Template))\n#4 /var/www/ojs/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_5d1df807babc90_24802726(Object(Smarty_Internal_Template))\n#5 /var/www/ojs/lib/pkp/lib/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.p in /var/www/ojs/plugins/generic/webFeed/WebFeedBlockPlugin.inc.php on line 93
which has nothing to do with this problem to me.

Do you have any suggestion?

Thanks a lot

Hi @marcello8080,

You can probably resolve the TinyMCE problem by just hard-reloading in your browser – it sounds to me like cached old Javascript.

Alec Smecher
Public Knowledge Project Team

1 Like

I fixed it. Thanks.

I reinstalled the plugin and I refreshed OJS cache through the admin interface and TinyMCE is back to life.

Thanks a lot