[solved] ORCID plugin: "Please check your client id, scopes and redirect URIs"

I tried to set up the ORCID plugin for an OJS 3 installation at https://ojs.acmfccapixaba.org.br/, but faced the error message “Please check your client id, scopes and redirect URIs” when testing the public sandbox (i’m not an ORCID member, just user).

The client id and secret I copied and pasted, and the redirect URI is the domain (https://ojs.acmfccapixaba.org.br/; I even added an http-not-https version). Any ideas about what might I be missing?

Hi there, @leonardof! Alainna from ORCID here. :slight_smile:

I went to your installation at https://ojs.acmfccapixaba.org.br/ to test the ORCID iD connection. I noticed that the link is sending the user to the ORCID Sandbox – our testing server – and not the production ORCID server:


The issue is most likely that you have entered a production API client (for https://orcid.org/XXXX) and not a Sandbox API client. To fix this, update the settings in your ORCID Plugin to the non Sandbox option.

Let me know if this does not work.

1 Like

Thank you, that was it!

1 Like

Hi, I have the same problem, I tried to configure the ORCID plugin for an installation of OJS 3 in http://revistas.uniminuto.edu/index.php/Pers, but I found that it does not show me the authorization and I completed the form Registration (I am not a member of ORCID, only user).

The client ID and the secret that I copied and pasted, and the redirect URI is the domain http://revistas.uniminuto.edu/index.php/Pers

Any ideas about what could be happening to me?

Hello @Oscar_Ariza,

Could you share more information about the errors that you are seeing? I have successfully connected my ORCID iD during account registration – check the new user with the name “alainna”. :smile:

Hola tengo un problema con este Plugin, ya esta instalado pero cuando quiero activarlo me aparece:
Error grave: llamar a una función miembro getUserVar () en el arreglo en /home/hemeroteca/public_html/plugins/generic/orcidProfile/OrcidProfilePlugin.inc.php en la línea 353
Cual puede ser la razón, la versión de OJS que estoy utilizando es 2.4.8

Never tried the plugin with OJS 2.x

I guess it’s best to open a new question. This one is marked as answered.

@leonardof you are right. Thank you