[SOLVED] Native export/import OJS 3.1.0-1

I exported one submission in native xml fromat from one journal in OJS 3.1.0-1 and imported that xml into another journal within the same installation and when I upload xml and click on import nothing happens. I am moved to tab Result but nothing is displayed. Please advise.

Hi @vvucic

Hmmm… It could be that it take longer, so maybe you could try to wait a little bit longer and could you please also track/watch the error log file during that import?


There were a few fixes after the release, I believe these:

Maybe they help…

I applied the bothfixes and I still have teh same result as on screenshot
I waited for more than 20 minutes so I guess it is not question of time.
In logs I can see this only:
[Tue Feb 27 02:13:19.369067 2018] [:error] [pid 32584] [client] PHP Warning: array_merge(): Argument #2 is not an array in /var/sentora/hostdata/admin/public_html/thermal-science_tech/journal/lib/pkp/classes/core/PKPApplication.inc.php on line 578
[Tue Feb 27 02:13:19.369136 2018] [:error] [pid 32584] [client] PHP Warning: Invalid argument supplied for foreach() in /var/sentora/hostdata/admin/public_html/thermal-science_tech/journal/plugins/generic/recommendByAuthor/RecommendByAuthorPlugin.inc.php on line 114
Please advise

Hi @vvucic

Would it be possible for you to send me (either private here in the forum or to bozana dot bokan at posteo dot net) the import XML file? – at the moment I have to further ideas… :-\


Hello, I will upload it to server and send you link so you can download it. OK?

The issue is solved by increasing execution time in php.ini and memory the script can take. In my case it is increased up to 128MB.