[SOLVED] Links and Images from Edition Text are not shown

In the edition text, that is shown near the over image, I have links to a BibTeX file and a PDF, as well as an image linking to lulu.com to buy a printed version, but it is now shown in the website. But if I open it on the backend, on tinyMCE, it shows correctly.

Help is welcome.
OJS 3.1.1 after migration from OJS 2.3.4

Hi @ambs,

Check the mark-up that’s showing up on the front end. Is it complete or have some elements been removed from it? Are there e.g. relative paths that are not correct in the context it’s being displayed?

Alec Smecher
Public Knowledge Project Team

Hi, @asmecher,

I was expecting links to show up, even if their target is broken. For the image, I can understand why it is not showing :slight_smile: but unless OJS checks links validity, it is weird they not being shown…


Hi @ambs,

For HTML-enabled inputs, OJS uses HTML Purifier to clean out user-supplied HTML and ensure that it’s safe. There’s an entry in config.inc.php called allowed_html that specifies what elements are allowed. I suspect you’re using something outside that list.

Alec Smecher
Public Knowledge Project Team

Thanks for the pointer. Will check and report here my findings.

allowed_html option is correct (also, the text was already there with OJS 2.3.x)

Hi, @asmecher.

Did some more experiences. All the HTML is stripped in that field. Tried a simple bold, and it disappears. Is there any kind of configuration to specify if some fields should be or now aware of the HTML?

Example, in http://linguamatica.perl-hackers.net/index.php/linguamatica/issue/view/1 (EN version), the description " First Linguamática edition is available. You can grab a PDF with the full issue." has a <br/> between the two sentences, the word <b>Linguamática</b> in bold and a link (<a href="...">PDF</a>).

Other places (like the journal footer) the HTML works pretty well. Just in this field I find out this problem.

Thank you in advance.

EDIT 1: Just noticed abstracts are not showing correctly formatted.

The syntax for the allowed_html config changed. I checked I had it, but I did not compare it with the template version of the config file.

Solved :heavy_heart_exclamation: