[Solved] Error during Install of OJS 3.1.2 on Reclaim Hosting

I’m trying to install OJS 3.1.2. on my Reclaim Hosting account. When I get to the Installation GUI page, I left all the settings to default.

But I get an error message: “A database error has occurred: Access denied for user ‘ojs2’@‘localhost’ (using password: YES)”

I’ve tried with a password and without a password to no avail. Reclaim support suggested i create the db first and then run the install, so I did that. And looking at other posts on this forum, I tried to Grant all privileges using phpMyAdmin, but got this error message:


Not sure what I’m doing wrong here or what to try next and hoping someone can assist.


I would do it like this:
1.- create database
2.- create user for that database, with all the privileges
3.- use the created user and the database for the installation
4.- uncheck “create new database” in the installation

it should work

Thanks. Unfortunately, I tried that already. Same “access denied for user” error.

The “Access denied for user” error indicates that the user darrenha@localhost does not have permission to GRANT ALL PRIVILEGES ON *.*. This is not surprising in a shared environment, as you are trying to affect every table of every database.

Try being more explicit in your GRANT statement to only affect the new ojs2 database:
GRANT ALL PRIVILEGES ON darrenha_ojs2.* to ojs2@localhost IDENTIFIED BY "yourpasswordhere"

Also note that in a shared environment, your actual mysql username for OJS may be prefixed with your account name, like:
GRANT ALL PRIVILEGES ON darrenha_ojs2.* to darrenha_ojs2@localhost IDENTIFIED BY "yourpasswordhere"

Thanks, I eventually got it to work and completed the install. On the install side, I was not giving the proper name of the database, because I neglected to include the account name prefix.