Send email to user from OJS

Description of issue or problem I’m having:

Steps I took leading up to the issue:
i have this user in OJS with this roles see image, He was sending emails to regular users, but he no longer has that role, I haven’t changed anything in OJS.
help please.

What I tried to resolve the issue:
I have tried the email used by OJS in the server, it sends and receives normally

Application Version - e.g., OJS 3.1.2:
3.3.0.8

Additional information, such as screenshots and error log messages if applicable:
Error-email

Hi @rebas_saber,

Can you please provide a bit more detail about the problem you are seeing? In particular please clarify what you mean by:

He was sending emails to regular users, but he no longer has that role

Is this user no longer able to send emails to other users? If so, can you please explain step by step what they are trying, and what issue they are encountering? Or is this user no longer receiving emails sent to them from the journal?

Thank you,

Kate

Hi @kshuttle , thanks for reply.

Yes, that’s what I want to say.

Explanation of what the user does step by step:

  • Access to the journal (backend)
  • Click on “Users and Roles”
  • Choose any user and then click on it
  • Then click on an email
  • Then fill in the required fields (subjects, body)
  • Finally, click on “Send an email”.

See Error in image :point_down: :point_down: :point_down:

321684165165169

But in my account as a “Journal manager” I send emails without errors.
@kshuttle Help please.

Hi @rebas_saber,
Thanks for providing the additional information. I will ask for one of my colleagues to weigh-in with their thoughts on this issue.
Best regards,
Kate

Thanks a lot @kshuttle

I would like to make another addition, I installed a new ojs last week, in a new domain and new hosting, I set up the mail in “config” but it didn’t work.

Please take a look at your error log, immediately after seeing this message on the web interface.

What can you find there?

Hi @janiosarmento Thanks for reply.

These mistakes are being repeated a lot this month.
Error log :

[05-Mar-2022 17:38:18 UTC] PHP Deprecated: Non-static method PKPApplication::getRequest() should not be called statically in /xxx/xxx/xxx/plugins/generic/publons/PublonsPlugin.inc.php on line 190
[05-Mar-2022 17:38:22 UTC] PHP Fatal error: Uncaught Error: Call to a member function getId() on null in /xxx/xxx/xxx/plugins/generic/webFeed/WebFeedBlockPlugin.inc.php:85
Stack trace:

What’s the PHP version on your server?

The error messages suggest you have issues with two plugins: webFeed and publons. Unfortunately I can’t help further than suggesting you to disable/remove both and see how things develop.

@janiosarmento

PHP Version 7.4.28

It seems that the issue comes from the plugin. If the PHP version is up to date, then the plugins should be updated. Your log tells that the syntax in the plugin is deprecated (which means should be updated). Some functions in PHP 5 are deprecated in PHP 7x.

1 Like